summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng-2.0/lttng-tools_2.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/lttng-2.0/lttng-tools_2.1.0.bb')
-rw-r--r--meta/recipes-kernel/lttng-2.0/lttng-tools_2.1.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng-2.0/lttng-tools_2.1.0.bb b/meta/recipes-kernel/lttng-2.0/lttng-tools_2.1.0.bb
new file mode 100644
index 0000000000..482b9a673f
--- /dev/null
+++ b/meta/recipes-kernel/lttng-2.0/lttng-tools_2.1.0.bb
@@ -0,0 +1,37 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit Control"
3DESCRIPTION = "The Linux trace toolkit is a suite of tools designed \
4to extract program execution details from the Linux operating system \
5and interpret them."
6
7LICENSE = "GPLv2 & LGPLv2.1"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=01d7fc4496aacf37d90df90b90b0cac1 \
9 file://gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
10 file://lgpl-2.1.txt;md5=0f0d71500e6a57fd24d825f33242b9ca"
11
12DEPENDS = "liburcu popt lttng2-ust"
13
14SRCREV = "917f768512b5d336d553b801f6c5308d90252a89"
15PV = "v2.1.0"
16PR = "r0"
17
18SRC_URI = "git://git.lttng.org/lttng-tools.git;protocol=git"
19
20S = "${WORKDIR}/git"
21
22inherit autotools
23
24export KERNELDIR="${STAGING_KERNEL_DIR}"
25
26FILES_${PN} += "${libdir}/lttng/libexec/*"
27FILES_${PN}-dbg += "${libdir}/lttng/libexec/.debug"
28
29# Since files are installed into ${libdir}/lttng/libexec we match
30# the libexec insane test so skip it.
31INSANE_SKIP_${PN} = "libexec"
32INSANE_SKIP_${PN}-dbg = "libexec"
33
34# Due to liburcu not building for MIPS currently this recipe needs to
35# be limited also.
36# So here let us first suppport x86/arm/powerpc platforms now.
37COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|powerpc.*)-linux.*'