summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_4.1.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.1.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.1.bb b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
new file mode 100644
index 0000000000..a7a52cb627
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
@@ -0,0 +1,41 @@
1KBRANCH ?= "standard/base"
2
3require recipes-kernel/linux/linux-yocto.inc
4
5# board specific branches
6KBRANCH_qemuarm ?= "standard/arm-versatile-926ejs"
7KBRANCH_qemuarm64 ?= "standard/qemuarm64"
8KBRANCH_qemumips ?= "standard/mti-malta32"
9KBRANCH_qemuppc ?= "standard/qemuppc"
10KBRANCH_qemux86 ?= "standard/base"
11KBRANCH_qemux86-64 ?= "standard/base"
12KBRANCH_qemumips64 ?= "standard/mti-malta64"
13
14SRCREV_machine_qemuarm ?= "c4df99c91fc947afb7010a11eceeef0e05bf964f"
15SRCREV_machine_qemuarm64 ?= "4e30e64c44df9e59bd13239951bb8d2b5b276e6f"
16SRCREV_machine_qemumips ?= "6a24f7e60b9b2ecc1579f5f767be5845086533e1"
17SRCREV_machine_qemuppc ?= "4e30e64c44df9e59bd13239951bb8d2b5b276e6f"
18SRCREV_machine_qemux86 ?= "4e30e64c44df9e59bd13239951bb8d2b5b276e6f"
19SRCREV_machine_qemux86-64 ?= "4e30e64c44df9e59bd13239951bb8d2b5b276e6f"
20SRCREV_machine_qemumips64 ?= "5c2b3697082a4ec6641aa5a8eca3974ca609cecf"
21SRCREV_machine ?= "4e30e64c44df9e59bd13239951bb8d2b5b276e6f"
22SRCREV_meta ?= "45393dd54f5ad77d43014c407c2b3520da42f427"
23
24SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;name=machine;branch=${KBRANCH}; \
25 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.1;destsuffix=${KMETA}"
26
27LINUX_VERSION ?= "4.1.2"
28
29PV = "${LINUX_VERSION}+git${SRCPV}"
30
31KMETA = "kernel-meta"
32KCONF_BSP_AUDIT_LEVEL = "2"
33
34COMPATIBLE_MACHINE = "qemuarm|qemuarm64|qemux86|qemuppc|qemumips|qemumips64|qemux86-64"
35
36# Functionality flags
37KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
38KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
39KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
40KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc"
41KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"