summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_3.17.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_3.17.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.17.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.17.bb b/meta/recipes-kernel/linux/linux-yocto_3.17.bb
new file mode 100644
index 0000000000..bba070e0e2
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto_3.17.bb
@@ -0,0 +1,37 @@
1KBRANCH ?= "standard/base"
2
3require recipes-kernel/linux/linux-yocto.inc
4
5# board specific branches
6KBRANCH_qemuarm ?= "standard/arm-versatile-926ejs"
7KBRANCH_qemumips ?= "standard/mti-malta32"
8KBRANCH_qemuppc ?= "standard/qemuppc"
9KBRANCH_qemux86 ?= "standard/common-pc"
10KBRANCH_qemux86-64 ?= "standard/common-pc-64/base"
11KBRANCH_qemumips64 ?= "standard/mti-malta64"
12
13SRCREV_machine_qemuarm ?= "12991e8ac40c51ef3e337f17f12aa59c6500fc7f"
14SRCREV_machine_qemumips ?= "1f4735ed314defc95ab9929258ad12844cc2c676"
15SRCREV_machine_qemuppc ?= "3231dececf867215ecab7c7f9ec3a7a7640a3f32"
16SRCREV_machine_qemux86 ?= "0409b1fbed221e61212e17b7637fa54f908d83f6"
17SRCREV_machine_qemux86-64 ?= "0409b1fbed221e61212e17b7637fa54f908d83f6"
18SRCREV_machine_qemumips64 ?= "7005c584078109dae03567e9c597a847a2bc5136"
19SRCREV_machine ?= "0409b1fbed221e61212e17b7637fa54f908d83f6"
20SRCREV_meta ?= "f24c2bf9c298595d00a9d8600841f2b0206e1fba"
21
22SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.17.git;bareclone=1;branch=${KBRANCH},${KMETA};name=machine,meta"
23
24LINUX_VERSION ?= "3.17.8"
25
26PV = "${LINUX_VERSION}+git${SRCPV}"
27
28KMETA = "meta"
29
30COMPATIBLE_MACHINE = "qemuarm|qemux86|qemuppc|qemumips|qemumips64|qemux86-64"
31
32# Functionality flags
33KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
34KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
35KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
36KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc"
37KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"