summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_5.19.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_5.19.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_5.19.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.19.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.19.bb
new file mode 100644
index 0000000000..716e5aa652
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.19.bb
@@ -0,0 +1,30 @@
1KBRANCH ?= "v5.19/standard/tiny/base"
2
3LINUX_KERNEL_TYPE = "tiny"
4KCONFIG_MODE = "--allnoconfig"
5
6require recipes-kernel/linux/linux-yocto.inc
7
8LINUX_VERSION ?= "5.19"
9LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
10
11DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
12DEPENDS += "openssl-native util-linux-native"
13
14KMETA = "kernel-meta"
15KCONF_BSP_AUDIT_LEVEL = "2"
16
17SRCREV_machine ?= "43e6ab6ed043f4bc8e7cffbb08af86af0bdb5e12"
18SRCREV_meta ?= "eb7088accaa0347a5b627952e48bb8800ff15cf3"
19
20PV = "${LINUX_VERSION}+git${SRCPV}"
21
22SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
23 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.19;destsuffix=${KMETA}"
24
25COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm64|qemuarm|qemuarmv5"
26
27# Functionality flags
28KERNEL_FEATURES = ""
29
30KERNEL_DEVICETREE:qemuarmv5 = "versatile-pb.dtb"