summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_5.13.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_5.13.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_5.13.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.13.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.13.bb
new file mode 100644
index 0000000000..f01133c761
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.13.bb
@@ -0,0 +1,32 @@
1KBRANCH ?= "v5.13/standard/tiny/base"
2KBRANCH_qemuarm ?= "v5.13/standard/tiny/arm-versatile-926ejs"
3
4LINUX_KERNEL_TYPE = "tiny"
5KCONFIG_MODE = "--allnoconfig"
6
7require recipes-kernel/linux/linux-yocto.inc
8
9LINUX_VERSION ?= "5.13"
10LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
11
12DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
13DEPENDS += "openssl-native util-linux-native"
14
15KMETA = "kernel-meta"
16KCONF_BSP_AUDIT_LEVEL = "2"
17
18SRCREV_machine_qemuarm ?= "84e5292c5adf2e715e842a9eb3985034941e0798"
19SRCREV_machine ?= "b1cead8d98582ca687f93e06438543b97144e5bf"
20SRCREV_meta ?= "ceb5fa598d08902fe2934c041875aa92d9a6fa19"
21
22PV = "${LINUX_VERSION}+git${SRCPV}"
23
24SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
25 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.13;destsuffix=${KMETA}"
26
27COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm|qemuarmv5"
28
29# Functionality flags
30KERNEL_FEATURES = ""
31
32KERNEL_DEVICETREE_qemuarmv5 = "versatile-pb.dtb"