summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_3.17.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_3.17.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_3.17.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_3.17.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_3.17.bb
new file mode 100644
index 0000000000..853f8d0289
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_3.17.bb
@@ -0,0 +1,21 @@
1KBRANCH ?= "standard/tiny/base"
2LINUX_KERNEL_TYPE = "tiny"
3KCONFIG_MODE = "--allnoconfig"
4
5require recipes-kernel/linux/linux-yocto.inc
6
7LINUX_VERSION ?= "3.17.8"
8
9KMETA = "meta"
10
11SRCREV_machine ?= "0409b1fbed221e61212e17b7637fa54f908d83f6"
12SRCREV_meta ?= "f24c2bf9c298595d00a9d8600841f2b0206e1fba"
13
14PV = "${LINUX_VERSION}+git${SRCPV}"
15
16SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.17.git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
17
18COMPATIBLE_MACHINE = "(qemux86)"
19
20# Functionality flags
21KERNEL_FEATURES = ""