summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-stable_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-stable_git.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-stable_git.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-stable_git.bb b/meta/recipes-kernel/linux/linux-yocto-stable_git.bb
index d4bee77c21..3c1e669733 100644
--- a/meta/recipes-kernel/linux/linux-yocto-stable_git.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-stable_git.bb
@@ -1,6 +1,7 @@
1inherit kernel 1inherit kernel
2require linux-yocto.inc 2require linux-yocto.inc
3 3
4KMACHINE = "common_pc"
4KMACHINE_qemux86 = "common_pc" 5KMACHINE_qemux86 = "common_pc"
5KMACHINE_qemux86-64 = "common_pc_64" 6KMACHINE_qemux86-64 = "common_pc_64"
6KMACHINE_qemuppc = "qemu_ppc32" 7KMACHINE_qemuppc = "qemu_ppc32"
@@ -14,20 +15,19 @@ KMACHINE_beagleboard = "beagleboard"
14LINUX_VERSION ?= "2.6.34" 15LINUX_VERSION ?= "2.6.34"
15LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE_EXTENSION}" 16LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE_EXTENSION}"
16 17
18KMETA = wrs_meta
19KBRANCH = ${KMACHINE}-${LINUX_KERNEL_TYPE_EXTENSION}
20
17PR = "r1" 21PR = "r1"
18PV = "${LINUX_VERSION}+git${SRCPV}" 22PV = "${LINUX_VERSION}+git${SRCPV}"
19SRCREV_FORMAT = "meta_machine" 23SRCREV_FORMAT = "meta_machine"
20 24
21COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64|atom-pc|routerstationpro|mpc8315e-rdb|beagleboard)" 25COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64|atom-pc|routerstationpro|mpc8315e-rdb|beagleboard)"
22 26
23# this performs a fixup on the SRCREV for new/undefined BSPs 27# this performs a fixup on historical kernel types with embedded _'s
24python __anonymous () { 28python __anonymous () {
25 import bb, re, string 29 import bb, re, string
26 30
27 rev = bb.data.getVar("SRCREV_machine", d, 1)
28 if rev == "standard":
29 bb.data.setVar("SRCREV_machine", "${SRCREV_meta}", d)
30
31 kerntype = string.replace(bb.data.expand("${LINUX_KERNEL_TYPE}", d), "_", "-") 31 kerntype = string.replace(bb.data.expand("${LINUX_KERNEL_TYPE}", d), "_", "-")
32 bb.data.setVar("LINUX_KERNEL_TYPE_EXTENSION", kerntype, d) 32 bb.data.setVar("LINUX_KERNEL_TYPE_EXTENSION", kerntype, d)
33} 33}