summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/latencytop/latencytop_0.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/latencytop/latencytop_0.5.bb')
-rw-r--r--meta/recipes-kernel/latencytop/latencytop_0.5.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-kernel/latencytop/latencytop_0.5.bb b/meta/recipes-kernel/latencytop/latencytop_0.5.bb
new file mode 100644
index 0000000000..e910a96f43
--- /dev/null
+++ b/meta/recipes-kernel/latencytop/latencytop_0.5.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Linux tool for measuring and fixing latency"
2HOMEPAGE = "http://www.latencytop.org/"
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://latencytop.c;endline=23;md5=ee9ea9b1415356e5734adad4a87dc7fa"
6
7DEPENDS = "virtual/libintl ncurses glib-2.0"
8
9PR = "r3"
10
11SRC_URI = "http://www.latencytop.org/download/latencytop-${PV}.tar.gz \
12 file://latencytop-makefile.patch \
13 file://latencytop-fsync.patch"
14
15SRC_URI[md5sum] = "73bb3371c6ee0b0e68e25289027e865c"
16SRC_URI[sha256sum] = "9e7f72fbea7bd918e71212a1eabaad8488d2c602205d2e3c95d62cd57e9203ef"
17
18PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
19
20PACKAGECONFIG[x11] = ",,gtk+"
21
22EXTRA_OEMAKE_X = "${@bb.utils.contains('PACKAGECONFIG', 'x11', 'HAS_GTK_GUI=1', '', d)}"
23
24CFLAGS += "${LDFLAGS}"
25
26do_install() {
27 oe_runmake install DESTDIR=${D} ${EXTRA_OEMAKE_X}
28}