summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/kmod/kmod_31.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/kmod/kmod_31.bb')
-rw-r--r--meta/recipes-kernel/kmod/kmod_31.bb89
1 files changed, 89 insertions, 0 deletions
diff --git a/meta/recipes-kernel/kmod/kmod_31.bb b/meta/recipes-kernel/kmod/kmod_31.bb
new file mode 100644
index 0000000000..718a5565b4
--- /dev/null
+++ b/meta/recipes-kernel/kmod/kmod_31.bb
@@ -0,0 +1,89 @@
1# Copyright (C) 2012 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Tools for managing Linux kernel modules"
5DESCRIPTION = "kmod is a set of tools to handle common tasks with Linux kernel modules like \
6 insert, remove, list, check properties, resolve dependencies and aliases."
7HOMEPAGE = "http://kernel.org/pub/linux/utils/kernel/kmod/"
8LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later"
9LICENSE:libkmod = "LGPL-2.1-or-later"
10SECTION = "base"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
13 file://libkmod/COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
14 file://tools/COPYING;md5=751419260aa954499f7abaabaa882bbe \
15 "
16inherit autotools bash-completion gtk-doc pkgconfig manpages update-alternatives
17
18SRCREV = "aff617ea871d0568cc491bd116c0be1e857463bb"
19
20SRC_URI = "git://git.kernel.org/pub/scm/utils/kernel/kmod/kmod.git;branch=master;protocol=https \
21 file://depmod-search.conf \
22 file://avoid_parallel_tests.patch \
23 file://0001-Use-portable-implementation-for-basename-API.patch \
24 file://gtkdocdir.patch \
25 "
26
27S = "${WORKDIR}/git"
28
29EXTRA_OECONF += "--enable-tools"
30
31PACKAGECONFIG ??= "zlib xz openssl"
32PACKAGECONFIG[debug] = "--enable-debug,--disable-debug"
33PACKAGECONFIG[logging] = " --enable-logging,--disable-logging"
34PACKAGECONFIG[manpages] = "--enable-manpages, --disable-manpages, libxslt-native xmlto-native"
35PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl"
36PACKAGECONFIG[xz] = "--with-xz,--without-xz,xz"
37PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib"
38PACKAGECONFIG[zstd] = "--with-zstd,--without-zstd,zstd"
39
40PROVIDES += "module-init-tools-insmod-static module-init-tools-depmod module-init-tools"
41RPROVIDES:${PN} += "module-init-tools-insmod-static module-init-tools-depmod module-init-tools"
42RCONFLICTS:${PN} += "module-init-tools-insmod-static module-init-tools-depmod module-init-tools"
43RREPLACES:${PN} += "module-init-tools-insmod-static module-init-tools-depmod module-init-tools"
44
45# to force user to remove old module-init-tools and replace them with kmod variants
46RCONFLICTS:libkmod2 += "module-init-tools-insmod-static module-init-tools-depmod module-init-tools"
47
48# autotools set prefix to /usr, however we want them in /bin and /sbin
49EXTRA_OECONF += "--bindir=${base_bindir} --sbindir=${base_sbindir}"
50
51do_install:append () {
52 install -dm755 ${D}${base_bindir}
53 install -dm755 ${D}${base_sbindir}
54 # add symlinks to kmod
55 ln -rs ${D}${base_bindir}/kmod ${D}${base_bindir}/lsmod
56 for tool in insmod rmmod depmod modinfo modprobe; do
57 ln -rs ${D}${base_bindir}/kmod ${D}${base_sbindir}/${tool}
58 done
59 # configuration directories
60 install -dm755 ${D}${nonarch_base_libdir}/depmod.d
61 install -dm755 ${D}${nonarch_base_libdir}/modprobe.d
62 install -dm755 ${D}${sysconfdir}/depmod.d
63 install -dm755 ${D}${sysconfdir}/modprobe.d
64
65 # install depmod.d file for search/ dir
66 install -Dm644 "${UNPACKDIR}/depmod-search.conf" "${D}${nonarch_base_libdir}/depmod.d/search.conf"
67
68 # Add .debug to the exclude path for depmod
69 echo "exclude .debug" > ${D}${nonarch_base_libdir}/depmod.d/exclude.conf
70}
71
72ALTERNATIVE_PRIORITY = "70"
73
74ALTERNATIVE:kmod = "insmod modprobe rmmod modinfo bin-lsmod lsmod depmod"
75
76ALTERNATIVE_LINK_NAME[depmod] = "${base_sbindir}/depmod"
77ALTERNATIVE_LINK_NAME[insmod] = "${base_sbindir}/insmod"
78ALTERNATIVE_LINK_NAME[modprobe] = "${base_sbindir}/modprobe"
79ALTERNATIVE_LINK_NAME[rmmod] = "${base_sbindir}/rmmod"
80ALTERNATIVE_LINK_NAME[modinfo] = "${base_sbindir}/modinfo"
81ALTERNATIVE_LINK_NAME[bin-lsmod] = "${base_bindir}/lsmod"
82ALTERNATIVE_LINK_NAME[lsmod] = "${base_sbindir}/lsmod"
83ALTERNATIVE_TARGET[lsmod] = "${base_bindir}/lsmod.${BPN}"
84
85PACKAGES =+ "libkmod"
86FILES:libkmod = "${base_libdir}/libkmod*${SOLIBS} ${libdir}/libkmod*${SOLIBS}"
87FILES:${PN} += "${nonarch_base_libdir}/depmod.d ${nonarch_base_libdir}/modprobe.d"
88
89BBCLASSEXTEND = "native nativesdk"