summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/kmod/kmod-native_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/kmod/kmod-native_git.bb')
-rw-r--r--meta/recipes-kernel/kmod/kmod-native_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-kernel/kmod/kmod-native_git.bb b/meta/recipes-kernel/kmod/kmod-native_git.bb
new file mode 100644
index 0000000000..f0e274ed79
--- /dev/null
+++ b/meta/recipes-kernel/kmod/kmod-native_git.bb
@@ -0,0 +1,18 @@
1# Copyright (C) 2012 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4require kmod.inc
5
6DEPENDS += "zlib-native"
7
8inherit native
9
10SRC_URI += "file://Change-to-calling-bswap_-instead-of-htobe-and-be-toh.patch \
11 "
12
13do_install_append (){
14 for tool in depmod insmod lsmod modinfo modprobe rmmod
15 do
16 ln -s kmod ${D}${bindir}/$tool
17 done
18}