summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/kmod/depmodwrapper-cross_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/kmod/depmodwrapper-cross_1.0.bb')
-rw-r--r--meta/recipes-kernel/kmod/depmodwrapper-cross_1.0.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-kernel/kmod/depmodwrapper-cross_1.0.bb b/meta/recipes-kernel/kmod/depmodwrapper-cross_1.0.bb
new file mode 100644
index 0000000000..efb1cac4c6
--- /dev/null
+++ b/meta/recipes-kernel/kmod/depmodwrapper-cross_1.0.bb
@@ -0,0 +1,43 @@
1DESCRIPTION = "Depmod wrapper script"
2LICENSE = "MIT"
3PR = "r0"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5
6# We need the following for the sstate code to process the wrapper
7SSTATE_SCAN_FILES += "depmodwrapper"
8
9do_install() {
10 install -d ${D}${bindir_crossscripts}/
11
12 cat > ${D}${bindir_crossscripts}/depmodwrapper << EOF
13#!/bin/sh
14# Expected to be called as: depmodwrapper -a KERNEL_VERSION
15if [ "\$1" != "-a" -o "\$2" != "-b" ]; then
16 echo "Usage: depmodwrapper -a -b rootfs KERNEL_VERSION" >&2
17 exit 1
18fi
19if [ ! -r ${STAGING_KERNEL_DIR}/kernel-abiversion ]; then
20 echo "Unable to read: ${STAGING_KERNEL_DIR}/kernel-abiversion" >&2
21else
22 kernelabi=\$(cat ${STAGING_KERNEL_DIR}/kernel-abiversion)
23 if [ "\$kernelabi" != "\$4" ]; then
24 echo "Error: Kernel version \$4 does not match kernel-abiversion (\$kernelabi)" >&2
25 exit 1
26 fi
27fi
28
29if [ ! -r ${STAGING_KERNEL_DIR}/System.map-\$4 ]; then
30 echo "Unable to read: ${STAGING_KERNEL_DIR}/System.map-\$4" >&2
31 exec env depmod "\$1" "\$2" "\$3" "\$4"
32else
33 exec env depmod "\$1" "\$2" "\$3" -F "${STAGING_KERNEL_DIR}/System.map-\$4" "\$4"
34fi
35EOF
36 chmod +x ${D}${bindir_crossscripts}/depmodwrapper
37}
38
39SYSROOT_PREPROCESS_FUNCS += "depmodwrapper_sysroot_preprocess"
40
41depmodwrapper_sysroot_preprocess () {
42 sysroot_stage_dir ${D}${bindir_crossscripts} ${SYSROOT_DESTDIR}${bindir_crossscripts}
43}