summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/kexec/kexec-tools_2.0.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/kexec/kexec-tools_2.0.18.bb')
-rw-r--r--meta/recipes-kernel/kexec/kexec-tools_2.0.18.bb87
1 files changed, 87 insertions, 0 deletions
diff --git a/meta/recipes-kernel/kexec/kexec-tools_2.0.18.bb b/meta/recipes-kernel/kexec/kexec-tools_2.0.18.bb
new file mode 100644
index 0000000000..b06c34392a
--- /dev/null
+++ b/meta/recipes-kernel/kexec/kexec-tools_2.0.18.bb
@@ -0,0 +1,87 @@
1
2SUMMARY = "Kexec fast reboot tools"
3DESCRIPTION = "Kexec is a fast reboot feature that lets you reboot to a new Linux kernel"
4AUTHOR = "Eric Biederman"
5HOMEPAGE = "http://kernel.org/pub/linux/utils/kernel/kexec/"
6SECTION = "kernel/userland"
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=ea5bed2f60d357618ca161ad539f7c0a \
9 file://kexec/kexec.c;beginline=1;endline=20;md5=af10f6ae4a8715965e648aa687ad3e09"
10DEPENDS = "zlib xz"
11
12SRC_URI = "${KERNELORG_MIRROR}/linux/utils/kernel/kexec/kexec-tools-${PV}.tar.gz \
13 file://kdump \
14 file://kdump.conf \
15 file://kdump.service \
16 file://0002-powerpc-change-the-memory-size-limit.patch \
17 file://0001-purgatory-Pass-r-directly-to-linker.patch \
18 file://0010-kexec-ARM-Fix-add_buffer_phys_virt-align-issue.patch \
19 file://kexec-x32.patch \
20 file://0001-Disable-PIE-during-link.patch \
21 "
22
23SRC_URI[md5sum] = "43845327af54b002aaebd5b8076c7bd7"
24SRC_URI[sha256sum] = "594ac13ea437c70b0d5f0eaf5075b93422b05c23c2a5e21991d2442bbd202d86"
25
26inherit autotools update-rc.d systemd
27
28export LDFLAGS = "-L${STAGING_LIBDIR}"
29EXTRA_OECONF = " --with-zlib=yes"
30
31do_compile_prepend() {
32 # Remove the prepackaged config.h from the source tree as it overrides
33 # the same file generated by configure and placed in the build tree
34 rm -f ${S}/include/config.h
35
36 # Remove the '*.d' file to make sure the recompile is OK
37 for dep in `find ${B} -type f -name '*.d'`; do
38 dep_no_d="`echo $dep | sed 's#.d$##'`"
39 # Remove file.d when there is a file.o
40 if [ -f "$dep_no_d.o" ]; then
41 rm -f $dep
42 fi
43 done
44}
45
46do_install_append () {
47 install -d ${D}${sysconfdir}/sysconfig
48 install -m 0644 ${WORKDIR}/kdump.conf ${D}${sysconfdir}/sysconfig
49
50 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
51 install -D -m 0755 ${WORKDIR}/kdump ${D}${sysconfdir}/init.d/kdump
52 fi
53
54 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
55 install -D -m 0755 ${WORKDIR}/kdump ${D}${libexecdir}/kdump-helper
56 install -D -m 0644 ${WORKDIR}/kdump.service ${D}${systemd_unitdir}/system/kdump.service
57 sed -i -e 's,@LIBEXECDIR@,${libexecdir},g' ${D}${systemd_unitdir}/system/kdump.service
58 fi
59}
60
61PACKAGES =+ "kexec kdump vmcore-dmesg"
62
63ALLOW_EMPTY_${PN} = "1"
64RRECOMMENDS_${PN} = "kexec kdump vmcore-dmesg"
65
66FILES_kexec = "${sbindir}/kexec"
67FILES_kdump = "${sbindir}/kdump \
68 ${sysconfdir}/sysconfig/kdump.conf \
69 ${sysconfdir}/init.d/kdump \
70 ${libexecdir}/kdump-helper \
71 ${systemd_unitdir}/system/kdump.service \
72"
73
74FILES_vmcore-dmesg = "${sbindir}/vmcore-dmesg"
75
76INITSCRIPT_PACKAGES = "kdump"
77INITSCRIPT_NAME_kdump = "kdump"
78INITSCRIPT_PARAMS_kdump = "start 56 2 3 4 5 . stop 56 0 1 6 ."
79
80SYSTEMD_PACKAGES = "kdump"
81SYSTEMD_SERVICE_kdump = "kdump.service"
82
83SECURITY_PIE_CFLAGS_remove = "-fPIE -pie"
84
85COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|aarch64.*|powerpc.*|mips.*)-(linux|freebsd.*)'
86
87INSANE_SKIP_${PN} = "arch"