summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/dtc/dtc_1.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/dtc/dtc_1.7.0.bb')
-rw-r--r--meta/recipes-kernel/dtc/dtc_1.7.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-kernel/dtc/dtc_1.7.0.bb b/meta/recipes-kernel/dtc/dtc_1.7.0.bb
new file mode 100644
index 0000000000..0702fc16df
--- /dev/null
+++ b/meta/recipes-kernel/dtc/dtc_1.7.0.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Device Tree Compiler"
2HOMEPAGE = "https://devicetree.org/"
3DESCRIPTION = "The Device Tree Compiler is a toolchain for working with device tree source and binary files."
4SECTION = "bootloader"
5LICENSE = "GPL-2.0-only | BSD-2-Clause"
6
7LIC_FILES_CHKSUM = "file://GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://BSD-2-Clause;md5=5d6306d1b08f8df623178dfd81880927 \
9 file://README.license;md5=a1eb22e37f09df5b5511b8a278992d0e"
10
11SRC_URI = " \
12 git://git.kernel.org/pub/scm/utils/dtc/dtc.git;branch=main;protocol=https \
13 file://0001-meson.build-bump-version-to-1.7.0.patch \
14 file://0002-meson-allow-building-from-shallow-clones.patch \
15"
16SRCREV = "039a99414e778332d8f9c04cbd3072e1dcc62798"
17
18UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
19
20S = "${WORKDIR}/git"
21
22inherit meson pkgconfig
23
24EXTRA_OEMESON = "-Dpython=disabled -Dvalgrind=disabled"
25
26PACKAGECONFIG ??= "tools"
27PACKAGECONFIG[tools] = "-Dtools=true,-Dtools=false,flex-native bison-native"
28PACKAGECONFIG[yaml] = "-Dyaml=enabled,-Dyaml=disabled,libyaml"
29
30PACKAGES =+ "${PN}-misc"
31FILES:${PN}-misc = "${bindir}/convert-dtsv0 ${bindir}/ftdump ${bindir}/dtdiff"
32RDEPENDS:${PN}-misc += "${@bb.utils.contains('PACKAGECONFIG', 'tools', 'bash diffutils', '', d)}"
33
34BBCLASSEXTEND = "native nativesdk"