summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/cryptodev/cryptodev-tests_1.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/cryptodev/cryptodev-tests_1.6.bb')
-rw-r--r--meta/recipes-kernel/cryptodev/cryptodev-tests_1.6.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-kernel/cryptodev/cryptodev-tests_1.6.bb b/meta/recipes-kernel/cryptodev/cryptodev-tests_1.6.bb
new file mode 100644
index 0000000000..efc41ae427
--- /dev/null
+++ b/meta/recipes-kernel/cryptodev/cryptodev-tests_1.6.bb
@@ -0,0 +1,23 @@
1require cryptodev_${PV}.inc
2
3SUMMARY = "A test suite for /dev/crypto device driver"
4
5DEPENDS += "openssl"
6
7SRC_URI += " \
8file://0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch \
9file://0002-Fix-tests-Makefile-usage-of-LDLIBS-vs.-LDFLAGS.patch \
10"
11
12EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"'
13
14do_compile() {
15 oe_runmake testprogs
16}
17
18do_install() {
19 oe_runmake install_tests
20}
21
22FILES_${PN}-dbg += "${bindir}/tests_cryptodev/.debug"
23FILES_${PN} = "${bindir}/tests_cryptodev/*"