summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/blktrace/blktrace_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/blktrace/blktrace_git.bb')
-rw-r--r--meta/recipes-kernel/blktrace/blktrace_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-kernel/blktrace/blktrace_git.bb b/meta/recipes-kernel/blktrace/blktrace_git.bb
new file mode 100644
index 0000000000..7a329934b8
--- /dev/null
+++ b/meta/recipes-kernel/blktrace/blktrace_git.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Generates traces of I/O traffic on block devices"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
4
5DEPENDS = "libaio"
6
7SRCREV = "d6918c8832793b4205ed3bfede78c2f915c23385"
8
9PR = "r6"
10PV = "1.0.5+git${SRCPV}"
11
12SRC_URI = "git://git.kernel.dk/blktrace.git \
13 file://ldflags.patch"
14
15S = "${WORKDIR}/git"
16
17EXTRA_OEMAKE = "\
18 'CC=${CC}' \
19 'CFLAGS=${CFLAGS}' \
20 'LDFLAGS=${LDFLAGS}' \
21"
22PARALLEL_MAKE = ""
23
24do_install() {
25 oe_runmake ARCH="${ARCH}" prefix=${prefix} \
26 mandir=${mandir} DESTDIR=${D} install
27}
28