summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xwayland/xwayland_23.2.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/xwayland/xwayland_23.2.6.bb')
-rw-r--r--meta/recipes-graphics/xwayland/xwayland_23.2.6.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xwayland/xwayland_23.2.6.bb b/meta/recipes-graphics/xwayland/xwayland_23.2.6.bb
new file mode 100644
index 0000000000..f51429bc8c
--- /dev/null
+++ b/meta/recipes-graphics/xwayland/xwayland_23.2.6.bb
@@ -0,0 +1,50 @@
1SUMMARY = "XWayland is an X Server that runs under Wayland."
2DESCRIPTION = "XWayland is an X Server running as a Wayland client, \
3and thus is capable of displaying native X11 client applications in a \
4Wayland compositor environment. The goal of XWayland is to facilitate \
5the transition from X Window System to Wayland environments, providing \
6a way to run unported applications in the meantime."
7HOMEPAGE = "https://fedoraproject.org/wiki/Changes/XwaylandStandalone"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=5df87950af51ac2c5822094553ea1880"
11
12SRC_URI = "https://www.x.org/archive/individual/xserver/xwayland-${PV}.tar.xz"
13SRC_URI[sha256sum] = "1c9a366b4e7ccadba0f9bd313c59eae12d23bd72543b22a26eaf8b20835cfc6d"
14
15UPSTREAM_CHECK_REGEX = "xwayland-(?P<pver>\d+(\.(?!90\d)\d+)+)\.tar"
16
17inherit meson features_check pkgconfig
18REQUIRED_DISTRO_FEATURES = "x11 opengl"
19
20DEPENDS += "xorgproto xtrans pixman libxkbfile libxfont2 wayland wayland-native wayland-protocols libdrm libepoxy libxcvt"
21
22OPENGL_PKGCONFIGS = "glx glamor dri3"
23PACKAGECONFIG ??= "${XORG_CRYPTO} ${XWAYLAND_EI} \
24 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '${OPENGL_PKGCONFIGS}', '', d)} \
25"
26PACKAGECONFIG[dri3] = "-Ddri3=true,-Ddri3=false,libxshmfence"
27PACKAGECONFIG[libdecor] = "-Dlibdecor=true,-Dlibdecor=false,libdecor"
28PACKAGECONFIG[glx] = "-Dglx=true,-Dglx=false,virtual/libgl virtual/libx11"
29PACKAGECONFIG[glamor] = "-Dglamor=true,-Dglamor=false,libepoxy virtual/libgbm,libegl"
30PACKAGECONFIG[unwind] = "-Dlibunwind=true,-Dlibunwind=false,libunwind"
31PACKAGECONFIG[xinerama] = "-Dxinerama=true,-Dxinerama=false"
32
33# Xorg requires a SHA1 implementation, pick one
34XORG_CRYPTO ??= "openssl"
35PACKAGECONFIG[openssl] = "-Dsha1=libcrypto,,openssl"
36PACKAGECONFIG[nettle] = "-Dsha1=libnettle,,nettle"
37PACKAGECONFIG[gcrypt] = "-Dsha1=libgcrypt,,libgcrypt"
38XWAYLAND_EI ??= "xwayland_ei_false"
39PACKAGECONFIG[xwayland_ei_false] = "-Dxwayland_ei=false"
40PACKAGECONFIG[xwayland_ei_portal] = "-Dxwayland_ei=portal,,libei"
41PACKAGECONFIG[xwayland_ei_socket] = "-Dxwayland_ei=socket,,libei"
42
43do_install:append() {
44 # remove files not needed and clashing with xserver-xorg
45 rm -rf ${D}/${libdir}/xorg/
46}
47
48FILES:${PN} += "${libdir}/xorg/protocol.txt"
49
50RDEPENDS:${PN} += "xkbcomp"