summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.27.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/xorg-lib/xkeyboard-config_2.27.bb')
-rw-r--r--meta/recipes-graphics/xorg-lib/xkeyboard-config_2.27.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.27.bb b/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.27.bb
new file mode 100644
index 0000000000..a6b2cc0eea
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.27.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Keyboard configuration database for X Window"
2
3DESCRIPTION = "The non-arch keyboard configuration database for X \
4Window. The goal is to provide the consistent, well-structured, \
5frequently released open source of X keyboard configuration data for X \
6Window System implementations. The project is targeted to XKB-based \
7systems."
8
9HOMEPAGE = "http://freedesktop.org/wiki/Software/XKeyboardConfig"
10BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=xkeyboard-config"
11
12LICENSE = "MIT & MIT-style"
13LIC_FILES_CHKSUM = "file://COPYING;md5=0e7f21ca7db975c63467d2e7624a12f9"
14
15SRC_URI = "${XORG_MIRROR}/individual/data/xkeyboard-config/${BPN}-${PV}.tar.bz2"
16
17SRC_URI[md5sum] = "316753e35d3906d042c74230612eab9f"
18SRC_URI[sha256sum] = "690daec8fea63526c07620c90e6f3f10aae34e94b6db6e30906173480721901f"
19
20SECTION = "x11/libs"
21DEPENDS = "intltool-native util-macros libxslt-native"
22
23EXTRA_OECONF = "--with-xkb-rules-symlink=xorg --disable-runtime-deps"
24
25FILES_${PN} += "${datadir}/X11/xkb"
26
27inherit autotools pkgconfig gettext
28
29do_install_append () {
30 install -d ${D}${datadir}/X11/xkb/compiled
31 cd ${D}${datadir}/X11/xkb/rules && ln -sf base xorg
32}