summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/xorg-lib/xkeyboard-config_2.20.bb')
-rw-r--r--meta/recipes-graphics/xorg-lib/xkeyboard-config_2.20.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.20.bb b/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.20.bb
new file mode 100644
index 0000000000..d00904df21
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.20.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Keyboard configuration database for X Window"
2
3DESCRIPTION = "The non-arch keyboard configuration database for X \
4Window. The goal is to provide the consistent, well-structured, \
5frequently released open source of X keyboard configuration data for X \
6Window System implementations. The project is targeted to XKB-based \
7systems."
8
9HOMEPAGE = "http://freedesktop.org/wiki/Software/XKeyboardConfig"
10BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=xkeyboard-config"
11
12LICENSE = "MIT & MIT-style"
13LIC_FILES_CHKSUM = "file://COPYING;md5=0e7f21ca7db975c63467d2e7624a12f9"
14
15SRC_URI = "${XORG_MIRROR}/individual/data/xkeyboard-config/${BPN}-${PV}.tar.bz2"
16SRC_URI[md5sum] = "1f68886339116ae3877052204c9b9b88"
17SRC_URI[sha256sum] = "d1bfc72553c4e3ef1cd6f13eec0488cf940498b612ab8a0b362e7090c94bc134"
18
19SECTION = "x11/libs"
20DEPENDS = "intltool-native virtual/gettext util-macros libxslt-native"
21
22EXTRA_OECONF = "--with-xkb-rules-symlink=xorg --disable-runtime-deps"
23
24FILES_${PN} += "${datadir}/X11/xkb"
25
26inherit autotools pkgconfig gettext
27
28do_install_append () {
29 install -d ${D}${datadir}/X11/xkb/compiled
30 cd ${D}${datadir}/X11/xkb/rules && ln -sf base xorg
31}