summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib/libxkbcommon_1.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/xorg-lib/libxkbcommon_1.7.0.bb')
-rw-r--r--meta/recipes-graphics/xorg-lib/libxkbcommon_1.7.0.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libxkbcommon_1.7.0.bb b/meta/recipes-graphics/xorg-lib/libxkbcommon_1.7.0.bb
new file mode 100644
index 0000000000..40cf616f0b
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libxkbcommon_1.7.0.bb
@@ -0,0 +1,40 @@
1SUMMARY = "Generic XKB keymap library"
2DESCRIPTION = "libxkbcommon is a keymap compiler and support library which \
3processes a reduced subset of keymaps as defined by the XKB specification."
4HOMEPAGE = "http://www.xkbcommon.org"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e525ed9809e1f8a07cf4bce8b09e8b87"
6LICENSE = "MIT & MIT"
7
8DEPENDS = "flex-native bison-native"
9
10SRC_URI = "http://xkbcommon.org/download/${BPN}-${PV}.tar.xz"
11
12SRC_URI[sha256sum] = "65782f0a10a4b455af9c6baab7040e2f537520caa2ec2092805cdfd36863b247"
13
14UPSTREAM_CHECK_URI = "http://xkbcommon.org/"
15
16inherit meson pkgconfig bash-completion
17
18PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'x11 wayland', d)} xkbregistry"
19
20PACKAGECONFIG[docs] = "-Denable-docs=true,-Denable-docs=false,doxygen-native"
21PACKAGECONFIG[wayland] = "-Denable-wayland=true,-Denable-wayland=false,wayland-native wayland wayland-protocols,"
22PACKAGECONFIG[x11] = "-Denable-x11=true,-Denable-x11=false,libxcb xkeyboard-config,"
23PACKAGECONFIG[xkbregistry] = "-Denable-xkbregistry=true,-Denable-xkbregistry=false,libxml2"
24
25PACKAGE_BEFORE_PN += "xkbcli"
26FILES:${PN} = ""
27FILES:xkbcli = "${bindir}/xkbcli ${libexecdir}/xkbcommon/xkbcli-*"
28
29python populate_packages:prepend () {
30 # Put the libraries into separate packages to avoid dependency creep
31 do_split_packages(d, d.expand('${libdir}'), r'^(lib.*)\.so\.*', '%s', '%s library', extra_depends='', allow_links=True)
32}
33
34# Fix a following runtime error:
35# xkbcommon: ERROR: couldn't find a Compose file for locale "C"
36RDEPENDS:${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', 'libx11-compose-data', d)}"
37
38BBCLASSEXTEND += "native"
39
40CVE_PRODUCT += "xkbcommon:libxkbcommon"