summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib/libxcb_1.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/xorg-lib/libxcb_1.14.bb')
-rw-r--r--meta/recipes-graphics/xorg-lib/libxcb_1.14.bb39
1 files changed, 0 insertions, 39 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libxcb_1.14.bb b/meta/recipes-graphics/xorg-lib/libxcb_1.14.bb
deleted file mode 100644
index e9f6051b6e..0000000000
--- a/meta/recipes-graphics/xorg-lib/libxcb_1.14.bb
+++ /dev/null
@@ -1,39 +0,0 @@
1SUMMARY = "XCB: The X protocol C binding library"
2DESCRIPTION = "The X protocol C-language Binding (XCB) is a replacement \
3for Xlib featuring a small footprint, latency hiding, direct access to \
4the protocol, improved threading support, and extensibility."
5HOMEPAGE = "http://xcb.freedesktop.org"
6BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=XCB"
7SECTION = "x11/libs"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=d763b081cb10c223435b01e00dc0aba7"
11
12SRC_URI = "http://xcb.freedesktop.org/dist/libxcb-${PV}.tar.xz \
13 file://disable-check.patch \
14 "
15
16SRC_URI[sha256sum] = "a55ed6db98d43469801262d81dc2572ed124edc3db31059d4e9916eb9f844c34"
17
18BBCLASSEXTEND = "native nativesdk"
19
20DEPENDS = "xcb-proto xorgproto libxau libpthread-stubs libxdmcp"
21
22PACKAGES_DYNAMIC = "^libxcb-.*"
23
24FILES_${PN} = "${libdir}/libxcb.so.*"
25
26inherit autotools pkgconfig features_check
27
28# The libxau and others requires x11 in DISTRO_FEATURES
29REQUIRED_DISTRO_FEATURES = "x11"
30
31export PYTHON = "python3"
32
33do_install_append () {
34 chown root.root ${D}${datadir}/doc/${BPN}/tutorial -R
35}
36
37python populate_packages_prepend () {
38 do_split_packages(d, '${libdir}', r'^libxcb-(.*)\.so\..*$', 'libxcb-%s', 'XCB library module for %s', allow_links=True)
39}