summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib/libxcb_1.13.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/xorg-lib/libxcb_1.13.bb')
-rw-r--r--meta/recipes-graphics/xorg-lib/libxcb_1.13.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libxcb_1.13.bb b/meta/recipes-graphics/xorg-lib/libxcb_1.13.bb
new file mode 100644
index 0000000000..04b58ea49f
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libxcb_1.13.bb
@@ -0,0 +1,39 @@
1SUMMARY = "XCB: The X protocol C binding library"
2DESCRIPTION = "The X protocol C-language Binding (XCB) is a replacement \
3for Xlib featuring a small footprint, latency hiding, direct access to \
4the protocol, improved threading support, and extensibility."
5HOMEPAGE = "http://xcb.freedesktop.org"
6BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=XCB"
7SECTION = "x11/libs"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=d763b081cb10c223435b01e00dc0aba7"
11
12SRC_URI = "http://xcb.freedesktop.org/dist/libxcb-${PV}.tar.bz2 \
13 file://xcbincludedir.patch \
14 file://disable-check.patch \
15 file://gcc-mips-pr68302-mips-workaround.patch \
16 "
17
18SRC_URI[md5sum] = "c2b6cf928afa16b0047c974e7aaa783f"
19SRC_URI[sha256sum] = "188c8752193c50ff2dbe89db4554c63df2e26a2e47b0fa415a70918b5b851daa"
20
21BBCLASSEXTEND = "native nativesdk"
22
23DEPENDS = "xcb-proto xproto libxau libpthread-stubs libxdmcp"
24
25PACKAGES_DYNAMIC = "^libxcb-.*"
26
27FILES_${PN} = "${libdir}/libxcb.so.*"
28
29inherit autotools pkgconfig distro_features_check
30
31# The libxau and others requires x11 in DISTRO_FEATURES
32REQUIRED_DISTRO_FEATURES = "x11"
33REQUIRED_DISTRO_FEATURES_class-native = ""
34
35export PYTHON = "python3"
36
37python populate_packages_prepend () {
38 do_split_packages(d, '${libdir}', '^libxcb-(.*)\.so\..*$', 'libxcb-%s', 'XCB library module for %s', allow_links=True)
39}