summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb')
-rw-r--r--meta/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb17
1 files changed, 8 insertions, 9 deletions
diff --git a/meta/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb b/meta/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb
index d2a16643fe..0516928a76 100644
--- a/meta/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb
+++ b/meta/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb
@@ -1,18 +1,17 @@
1SUMMARY = "Touchscreen calibration program for X11" 1SUMMARY = "Touchscreen calibration program for X11"
2HOMEPAGE = "http://www.freedesktop.org/wiki/Software/xinput_calibrator" 2HOMEPAGE = "http://www.freedesktop.org/wiki/Software/xinput_calibrator"
3LICENSE = "MIT-X" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://src/calibrator.cpp;endline=22;md5=1bcba08f67cdb56f34021557898e4b5a" 4LIC_FILES_CHKSUM = "file://src/calibrator.cpp;endline=22;md5=1bcba08f67cdb56f34021557898e4b5a"
5DEPENDS = "virtual/libx11 libxi libxrandr" 5DEPENDS = "virtual/libx11 libxi libxrandr"
6 6
7PV = "0.7.5+git${SRCPV}" 7PV = "0.7.5+git"
8PR = "r6"
9 8
10inherit autotools pkgconfig features_check 9inherit autotools pkgconfig features_check
11# depends on virtual/libx11 10# depends on virtual/libx11
12REQUIRED_DISTRO_FEATURES = "x11" 11REQUIRED_DISTRO_FEATURES = "x11"
13 12
14SRCREV = "18ec53f1cada39f905614ebfaffed5c7754ecf46" 13SRCREV = "18ec53f1cada39f905614ebfaffed5c7754ecf46"
15SRC_URI = "git://github.com/kreijack/xinput_calibrator.git;branch=libinput \ 14SRC_URI = "git://github.com/kreijack/xinput_calibrator.git;branch=libinput;protocol=https \
16 file://30xinput_calibrate.sh \ 15 file://30xinput_calibrate.sh \
17 file://Allow-xinput_calibrator_pointercal.sh-to-be-run-as-n.patch \ 16 file://Allow-xinput_calibrator_pointercal.sh-to-be-run-as-n.patch \
18 file://0001-calibrator.hh-Include-string-to-get-std-string.patch \ 17 file://0001-calibrator.hh-Include-string-to-get-std-string.patch \
@@ -23,17 +22,17 @@ S = "${WORKDIR}/git"
23# force native X11 ui as we don't have gtk+ in DEPENDS 22# force native X11 ui as we don't have gtk+ in DEPENDS
24EXTRA_OECONF += "--with-gui=x11" 23EXTRA_OECONF += "--with-gui=x11"
25 24
26do_install_append() { 25do_install:append() {
27 install -d ${D}${bindir} 26 install -d ${D}${bindir}
28 install -m 0755 ${S}/scripts/xinput_calibrator_pointercal.sh ${D}${bindir}/xinput_calibrator_once.sh 27 install -m 0755 ${S}/scripts/xinput_calibrator_pointercal.sh ${D}${bindir}/xinput_calibrator_once.sh
29 28
30 install -d ${D}${sysconfdir}/X11/Xsession.d/ 29 install -d ${D}${sysconfdir}/X11/Xsession.d/
31 install -m 0755 ${WORKDIR}/30xinput_calibrate.sh ${D}${sysconfdir}/X11/Xsession.d/ 30 install -m 0755 ${UNPACKDIR}/30xinput_calibrate.sh ${D}${sysconfdir}/X11/Xsession.d/
32 31
33 install -d ${D}${sysconfdir}/xdg/autostart 32 install -d ${D}${sysconfdir}/xdg/autostart
34 sed -e 's,^Exec=.*,Exec=${bindir}/xinput_calibrator_once.sh,' ${S}/scripts/xinput_calibrator.desktop > ${D}${sysconfdir}/xdg/autostart/xinput_calibrator.desktop 33 sed -e 's,^Exec=.*,Exec=${bindir}/xinput_calibrator_once.sh,' ${S}/scripts/xinput_calibrator.desktop > ${D}${sysconfdir}/xdg/autostart/xinput_calibrator.desktop
35} 34}
36 35
37FILES_${PN} += "${sysconfdir}/xdg/autostart" 36FILES:${PN} += "${sysconfdir}/xdg/autostart"
38RDEPENDS_${PN} = "xinput formfactor" 37RDEPENDS:${PN} = "xinput formfactor"
39RRECOMMENDS_${PN} = "pointercal-xinput" 38RRECOMMENDS:${PN} = "pointercal-xinput"