summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/wayland_1.3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/wayland/wayland_1.3.0.bb')
-rw-r--r--meta/recipes-graphics/wayland/wayland_1.3.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/wayland_1.3.0.bb b/meta/recipes-graphics/wayland/wayland_1.3.0.bb
new file mode 100644
index 0000000000..212e08ae1b
--- /dev/null
+++ b/meta/recipes-graphics/wayland/wayland_1.3.0.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Wayland, a protocol between a compositor and clients"
2DESCRIPTION = "Wayland is a protocol for a compositor to talk to its clients \
3as well as a C library implementation of that protocol. The compositor can be \
4a standalone display server running on Linux kernel modesetting and evdev \
5input devices, an X application, or a wayland client itself. The clients can \
6be traditional applications, X servers (rootless or fullscreen) or other \
7display servers."
8HOMEPAGE = "http://wayland.freedesktop.org"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=1d4476a7d98dd5691c53d4d43a510c72 \
11 file://src/wayland-server.c;endline=21;md5=079ae21dbf98ada52ec23744851b0a5c"
12
13SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
14SRC_URI[md5sum] = "d16d27081e0871de82d08840c2f133fc"
15SRC_URI[sha256sum] = "2e817685f68a26acd19964d69ddbc4549ba5412114ad95e1a9f5934cce470d6e"
16
17SRC_URI_append_class-native = " file://just-scanner.patch"
18
19inherit autotools pkgconfig
20
21# We need wayland-native for the wayland-scanner utility
22BBCLASSEXTEND = "native"
23
24DEPENDS_virtclass-native = "expat-native libffi-native"
25DEPENDS = "expat libffi wayland-native"
26
27EXTRA_OECONF_virtclass-native = "--disable-documentation"
28EXTRA_OECONF = "--disable-documentation --disable-scanner"
29
30# Wayland installs a M4 macro for other projects to use, which uses the target
31# pkg-config to find files. Replace pkg-config with pkg-config-native.
32do_install_append_class-native() {
33 sed -e 's,PKG_CHECK_MODULES(.*),,g' \
34 -e 's,$PKG_CONFIG,pkg-config-native,g' \
35 -i ${D}/${datadir}/aclocal/wayland-scanner.m4
36}