summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/wayland_1.19.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/wayland/wayland_1.19.0.bb')
-rw-r--r--meta/recipes-graphics/wayland/wayland_1.19.0.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/wayland_1.19.0.bb b/meta/recipes-graphics/wayland/wayland_1.19.0.bb
new file mode 100644
index 0000000000..8f121601c4
--- /dev/null
+++ b/meta/recipes-graphics/wayland/wayland_1.19.0.bb
@@ -0,0 +1,60 @@
1SUMMARY = "Wayland, a protocol between a compositor and clients"
2DESCRIPTION = "Wayland is a protocol for a compositor to talk to its clients \
3as well as a C library implementation of that protocol. The compositor can be \
4a standalone display server running on Linux kernel modesetting and evdev \
5input devices, an X application, or a wayland client itself. The clients can \
6be traditional applications, X servers (rootless or fullscreen) or other \
7display servers."
8HOMEPAGE = "http://wayland.freedesktop.org"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b31d8f53b6aaf2b4985d7dd7810a70d1 \
11 file://src/wayland-server.c;endline=24;md5=b8e046164a766bb1ede8ba38e9dcd7ce"
12
13DEPENDS = "expat libffi wayland-native"
14
15SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
16 file://run-ptest \
17 file://0002-meson.build-find-the-native-wayland-scanner-directly.patch \
18 file://0002-Do-not-hardcode-the-path-to-wayland-scanner.patch \
19 file://0001-build-Fix-strndup-detection-on-MinGW.patch \
20 "
21SRC_URI[sha256sum] = "baccd902300d354581cd5ad3cc49daa4921d55fb416a5883e218750fef166d15"
22
23UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html"
24
25inherit meson pkgconfig ptest
26
27PACKAGECONFIG ??= "dtd-validation"
28PACKAGECONFIG[dtd-validation] = "-Ddtd_validation=true,-Ddtd_validation=false,libxml2,,"
29
30EXTRA_OEMESON = "-Ddocumentation=false"
31EXTRA_OEMESON_class-native = "-Ddocumentation=false -Dlibraries=false"
32
33# Wayland installs a M4 macro for other projects to use, which uses the target
34# pkg-config to find files. Replace pkg-config with pkg-config-native.
35do_install_append_class-native() {
36 sed -e 's,PKG_CHECK_MODULES(.*),,g' \
37 -e 's,$PKG_CONFIG,pkg-config-native,g' \
38 -i ${D}/${datadir}/aclocal/wayland-scanner.m4
39}
40
41do_install_ptest() {
42 mkdir -p ${D}${PTEST_PATH}/tests/data
43 cp -rf ${B}/tests/*-test ${B}/tests/*-checker ${D}${PTEST_PATH}/tests
44 cp -rf ${B}/tests/*-checker ${D}${PTEST_PATH}
45 cp -rf ${S}/tests/scanner-test.sh ${D}${PTEST_PATH}/tests
46 cp -rf ${S}/tests/data/* ${D}${PTEST_PATH}/tests/data/
47 cp -rf ${S}/egl/wayland-egl-symbols-check ${D}${PTEST_PATH}/tests/
48}
49
50sysroot_stage_all_append_class-target () {
51 rm ${SYSROOT_DESTDIR}/${datadir}/aclocal/wayland-scanner.m4
52 cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/
53}
54
55FILES_${PN} = "${libdir}/*${SOLIBS}"
56FILES_${PN}-dev += "${bindir} ${datadir}/wayland"
57
58BBCLASSEXTEND = "native nativesdk"
59
60RDEPENDS_${PN}-ptest += "binutils sed"