summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/wayland_1.11.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/wayland/wayland_1.11.0.bb')
-rw-r--r--meta/recipes-graphics/wayland/wayland_1.11.0.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/wayland_1.11.0.bb b/meta/recipes-graphics/wayland/wayland_1.11.0.bb
new file mode 100644
index 0000000000..3413406d05
--- /dev/null
+++ b/meta/recipes-graphics/wayland/wayland_1.11.0.bb
@@ -0,0 +1,43 @@
1SUMMARY = "Wayland, a protocol between a compositor and clients"
2DESCRIPTION = "Wayland is a protocol for a compositor to talk to its clients \
3as well as a C library implementation of that protocol. The compositor can be \
4a standalone display server running on Linux kernel modesetting and evdev \
5input devices, an X application, or a wayland client itself. The clients can \
6be traditional applications, X servers (rootless or fullscreen) or other \
7display servers."
8HOMEPAGE = "http://wayland.freedesktop.org"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b31d8f53b6aaf2b4985d7dd7810a70d1 \
11 file://src/wayland-server.c;endline=24;md5=b8e046164a766bb1ede8ba38e9dcd7ce"
12
13SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
14 file://0001-scanner-Use-unit32_t-instead-of-uint.patch \
15 "
16SRC_URI[md5sum] = "fccf680be066e234729d5b69e0bd0fa9"
17SRC_URI[sha256sum] = "9540925f7928becfdf5e3b84c70757f6589bf1ceef09bea78784d8e4772c0db0"
18
19EXTRA_OECONF_class-native = "--disable-documentation --disable-libraries"
20
21inherit autotools pkgconfig
22
23BBCLASSEXTEND = "native nativesdk"
24
25DEPENDS = "expat libxml2 libffi wayland-native"
26
27EXTRA_OECONF = "--disable-documentation --with-host-scanner"
28
29# Wayland installs a M4 macro for other projects to use, which uses the target
30# pkg-config to find files. Replace pkg-config with pkg-config-native.
31do_install_append_class-native() {
32 sed -e 's,PKG_CHECK_MODULES(.*),,g' \
33 -e 's,$PKG_CONFIG,pkg-config-native,g' \
34 -i ${D}/${datadir}/aclocal/wayland-scanner.m4
35}
36
37sysroot_stage_all_append_class-target () {
38 rm ${SYSROOT_DESTDIR}/${datadir}/aclocal/wayland-scanner.m4
39 cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/
40}
41
42FILES_${PN} = "${libdir}/*${SOLIBS}"
43FILES_${PN}-dev += "${bindir} ${datadir}/wayland"