summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/libinput_1.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/wayland/libinput_1.6.1.bb')
-rw-r--r--meta/recipes-graphics/wayland/libinput_1.6.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/libinput_1.6.1.bb b/meta/recipes-graphics/wayland/libinput_1.6.1.bb
new file mode 100644
index 0000000000..c8714f23e7
--- /dev/null
+++ b/meta/recipes-graphics/wayland/libinput_1.6.1.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Library to handle input devices in Wayland compositors"
2HOMEPAGE = "http://www.freedesktop.org/wiki/Software/libinput/"
3SECTION = "libs"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;md5=2184aef38ff137ed33ce9a63b9d1eb8f"
7
8DEPENDS = "libevdev udev mtdev"
9
10SRC_URI = "http://www.freedesktop.org/software/${BPN}/${BP}.tar.xz \
11 file://touchpad-serial-synaptics-need-to-fake-new-touches-on-TRIPLETAP.patch \
12"
13SRC_URI[md5sum] = "7e282344f8ed7ec5cf87ca9fc22674fb"
14SRC_URI[sha256sum] = "9d816f13eee63bcca0e9c3bb652c52ab55f39be4d1b90b54e4bfd1dc92ef55a8"
15
16inherit autotools pkgconfig
17
18PACKAGECONFIG ??= ""
19PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
20PACKAGECONFIG[libwacom] = "--enable-libwacom,--disable-libwacom,libwacom"
21PACKAGECONFIG[gui] = "--enable-event-gui,--disable-event-gui,cairo gtk+3"
22
23UDEVDIR = "`pkg-config --variable=udevdir udev`"
24
25EXTRA_OECONF += "--with-udev-dir=${UDEVDIR}"