summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/libinput_1.25.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/wayland/libinput_1.25.0.bb')
-rw-r--r--meta/recipes-graphics/wayland/libinput_1.25.0.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/libinput_1.25.0.bb b/meta/recipes-graphics/wayland/libinput_1.25.0.bb
new file mode 100644
index 0000000000..894858e361
--- /dev/null
+++ b/meta/recipes-graphics/wayland/libinput_1.25.0.bb
@@ -0,0 +1,49 @@
1SUMMARY = "Library to handle input devices in Wayland compositors"
2DESCRIPTION = "libinput is a library to handle input devices in Wayland \
3compositors and to provide a generic X.Org input driver. It provides \
4device detection, device handling, input device event processing and \
5abstraction so minimize the amount of custom input code compositors need to \
6provide the common set of functionality that users expect."
7HOMEPAGE = "http://www.freedesktop.org/wiki/Software/libinput/"
8SECTION = "libs"
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://COPYING;md5=bab4ac7dc1c10bc0fb037dc76c46ef8a"
12
13DEPENDS = "libevdev udev mtdev"
14
15SRC_URI = "git://gitlab.freedesktop.org/libinput/libinput.git;protocol=https;branch=main \
16 file://run-ptest \
17 "
18SRCREV = "3fd38d89276b679ac3565efd7c2150fd047902cb"
19S = "${WORKDIR}/git"
20
21UPSTREAM_CHECK_REGEX = "libinput-(?P<pver>\d+\.\d+\.(?!9\d+)\d+)"
22
23inherit meson pkgconfig lib_package ptest
24
25# Patch out build directory, otherwise it leaks into ptest binary
26do_configure:append() {
27 sed -i -e "s,${WORKDIR},,g" config.h
28 if [ -e "litest-config.h" ]; then
29 sed -i -e "s,${WORKDIR},,g" litest-config.h
30 fi
31}
32
33PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
34PACKAGECONFIG[libwacom] = "-Dlibwacom=true,-Dlibwacom=false,libwacom"
35PACKAGECONFIG[gui] = "-Ddebug-gui=true,-Ddebug-gui=false,cairo gtk+3 wayland-native"
36PACKAGECONFIG[tests] = "-Dtests=true -Dinstall-tests=true,-Dtests=false -Dinstall-tests=false,libcheck"
37
38UDEVDIR = "`pkg-config --variable=udevdir udev`"
39
40EXTRA_OEMESON += "-Dudev-dir=${UDEVDIR} \
41 -Ddocumentation=false \
42 -Dzshcompletiondir=no"
43
44# package name changed in 1.8.1 upgrade: make sure package upgrades work
45RPROVIDES:${PN} = "libinput"
46RREPLACES:${PN} = "libinput"
47RCONFLICTS:${PN} = "libinput"
48
49FILES:${PN}-ptest += "${libexecdir}/libinput/libinput-test-suite"