summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/libinput_1.16.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/wayland/libinput_1.16.1.bb')
-rw-r--r--meta/recipes-graphics/wayland/libinput_1.16.1.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/libinput_1.16.1.bb b/meta/recipes-graphics/wayland/libinput_1.16.1.bb
new file mode 100644
index 0000000000..1497609183
--- /dev/null
+++ b/meta/recipes-graphics/wayland/libinput_1.16.1.bb
@@ -0,0 +1,49 @@
1SUMMARY = "Library to handle input devices in Wayland compositors"
2DESCRIPTION = "libinput is a library to handle input devices in Wayland \
3compositors and to provide a generic X.Org input driver. It provides \
4device detection, device handling, input device event processing and \
5abstraction so minimize the amount of custom input code compositors need to \
6provide the common set of functionality that users expect."
7HOMEPAGE = "http://www.freedesktop.org/wiki/Software/libinput/"
8SECTION = "libs"
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://COPYING;md5=1f2ea9ebff3a2c6d458faf58492efb63"
12
13DEPENDS = "libevdev udev mtdev libcheck"
14
15SRC_URI = "http://www.freedesktop.org/software/${BPN}/${BP}.tar.xz \
16 file://run-ptest \
17 file://determinism.patch \
18 "
19SRC_URI[sha256sum] = "7ba7d1aeedd15168bb21d17e9e628aa1c27957963a423a3fea3938a501758539"
20
21UPSTREAM_CHECK_REGEX = "libinput-(?P<pver>\d+\.\d+\.(?!9\d+)\d+)"
22
23inherit meson pkgconfig lib_package ptest
24
25# Patch out build directory, otherwise it leaks into ptest binary
26do_configure_append() {
27 sed -i -e "s,${WORKDIR},,g" config.h
28 if [ -e "litest-config.h" ]; then
29 sed -i -e "s,${WORKDIR},,g" litest-config.h
30 fi
31}
32
33PACKAGECONFIG ??= ""
34PACKAGECONFIG[libwacom] = "-Dlibwacom=true,-Dlibwacom=false,libwacom"
35PACKAGECONFIG[gui] = "-Ddebug-gui=true,-Ddebug-gui=false,cairo gtk+3"
36
37UDEVDIR = "`pkg-config --variable=udevdir udev`"
38
39EXTRA_OEMESON += "-Dudev-dir=${UDEVDIR} \
40 -Ddocumentation=false \
41 ${@bb.utils.contains('PTEST_ENABLED', '1', '-Dtests=true -Dinstall-tests=true', '-Dtests=false -Dinstall-tests=false', d)} \
42 -Dzshcompletiondir=no"
43
44# package name changed in 1.8.1 upgrade: make sure package upgrades work
45RPROVIDES_${PN} = "libinput"
46RREPLACES_${PN} = "libinput"
47RCONFLICTS_${PN} = "libinput"
48
49FILES_${PN}-ptest += "${libexecdir}/libinput/libinput-test-suite"