summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/waffle/waffle_1.7.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/waffle/waffle_1.7.2.bb')
-rw-r--r--meta/recipes-graphics/waffle/waffle_1.7.2.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-graphics/waffle/waffle_1.7.2.bb b/meta/recipes-graphics/waffle/waffle_1.7.2.bb
new file mode 100644
index 0000000000..cb917d8894
--- /dev/null
+++ b/meta/recipes-graphics/waffle/waffle_1.7.2.bb
@@ -0,0 +1,51 @@
1SUMMARY = "A C library for selecting an OpenGL API and window system at runtime"
2DESCRIPTION = "A cross-platform C library that allows one to defer selection \
3of an OpenGL API and window system until runtime. For example, on Linux, Waffle \
4enables an application to select X11/EGL with an OpenGL 3.3 core profile, \
5Wayland with OpenGL ES2, and other window system / API combinations."
6HOMEPAGE = "https://gitlab.freedesktop.org/mesa/waffle"
7BUGTRACKER = "https://gitlab.freedesktop.org/mesa/waffle"
8LICENSE = "BSD-2-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4c5154407c2490750dd461c50ad94797 \
10 file://include/waffle-1/waffle.h;endline=24;md5=61dbf8697f61c78645e75a93c585b1bf"
11
12SRC_URI = "git://gitlab.freedesktop.org/mesa/waffle.git;protocol=https;branch=maint-1.7 \
13 file://0001-waffle-do-not-make-core-protocol-into-the-library.patch \
14 file://0001-meson.build-request-native-wayland-scanner.patch \
15 "
16SRCREV = "f3b42a7216105498842bc6ba77d8481b90d6f5f9"
17S = "${WORKDIR}/git"
18
19inherit meson features_check lib_package bash-completion pkgconfig
20
21DEPENDS:append = " python3"
22
23# This should be overridden per-machine to reflect the capabilities of the GL
24# stack.
25PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'glx x11-egl', '', d)} \
26 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)} \
27 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gbm surfaceless-egl', '', d)} \
28"
29
30# virtual/libgl requires opengl in DISTRO_FEATURES.
31REQUIRED_DISTRO_FEATURES += "${@bb.utils.contains('DEPENDS', 'virtual/${MLPREFIX}libgl', 'opengl', '', d)}"
32
33# I say virtual/libgl, actually wants gl.pc
34PACKAGECONFIG[glx] = "-Dglx=enabled,-Dglx=disabled,virtual/${MLPREFIX}libgl libx11"
35
36# wants wayland-egl.pc, egl.pc, and the wayland
37# DISTRO_FEATURE.
38PACKAGECONFIG[wayland] = "-Dwayland=enabled,-Dwayland=disabled,virtual/${MLPREFIX}egl wayland wayland-native wayland-protocols"
39
40# wants gbm.pc egl.pc
41PACKAGECONFIG[gbm] = "-Dgbm=enabled,-Dgbm=disabled,virtual/${MLPREFIX}egl virtual/${MLPREFIX}libgbm udev"
42
43# wants egl.pc
44PACKAGECONFIG[x11-egl] = "-Dx11_egl=enabled,-Dx11_egl=disabled,virtual/${MLPREFIX}egl libxcb"
45PACKAGECONFIG[surfaceless-egl] = "-Dsurfaceless_egl=enabled,-Dsurfaceless_egl=disabled,virtual/${MLPREFIX}egl"
46
47# TODO: optionally build manpages and examples
48
49do_install:append() {
50 rm -rf ${D}${datadir}/zsh
51}