summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/vulkan/vulkan-tools_1.3.250.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/vulkan/vulkan-tools_1.3.250.0.bb')
-rw-r--r--meta/recipes-graphics/vulkan/vulkan-tools_1.3.250.0.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-graphics/vulkan/vulkan-tools_1.3.250.0.bb b/meta/recipes-graphics/vulkan/vulkan-tools_1.3.250.0.bb
new file mode 100644
index 0000000000..0346b380ee
--- /dev/null
+++ b/meta/recipes-graphics/vulkan/vulkan-tools_1.3.250.0.bb
@@ -0,0 +1,38 @@
1SUMMARY = "Vulkan Utilities and Tools"
2DESCRIPTION = "Assist development by enabling developers to verify their applications correct use of the Vulkan API."
3HOMEPAGE = "https://www.khronos.org/vulkan/"
4BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Tools"
5SECTION = "libs"
6
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
9SRC_URI = "git://github.com/KhronosGroup/Vulkan-Tools.git;branch=main;protocol=https \
10 file://0001-scripts-CMakeLists.txt-do-not-make-special-arrangeme.patch \
11 "
12SRCREV = "695887a994ef9cc00a7aa3f9c00b31a56ea79534"
13
14S = "${WORKDIR}/git"
15
16inherit cmake features_check pkgconfig
17ANY_OF_DISTRO_FEATURES = "x11 wayland"
18REQUIRED_DISTRO_FEATURES = "vulkan"
19
20DEPENDS += "vulkan-headers vulkan-loader"
21
22EXTRA_OECMAKE = "\
23 -DBUILD_TESTS=OFF \
24 -DBUILD_CUBE=OFF \
25 -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 \
26 "
27
28# must choose x11 or wayland or both
29PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
30
31PACKAGECONFIG[x11] = "-DBUILD_WSI_XLIB_SUPPORT=ON -DBUILD_WSI_XCB_SUPPORT=ON, -DBUILD_WSI_XLIB_SUPPORT=OFF -DBUILD_WSI_XCB_SUPPORT=OFF, libxcb libx11 libxrandr"
32PACKAGECONFIG[wayland] = "-DBUILD_WSI_WAYLAND_SUPPORT=ON, -DBUILD_WSI_WAYLAND_SUPPORT=OFF, wayland"
33
34# These recipes need to be updated in lockstep with each other:
35# glslang, vulkan-headers, vulkan-loader, vulkan-tools, spirv-headers, spirv-tools
36# The tags versions should always be sdk-x.y.z, as this is what
37# upstream considers a release.
38UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"