summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/vulkan/vulkan-samples_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/vulkan/vulkan-samples_git.bb')
-rw-r--r--meta/recipes-graphics/vulkan/vulkan-samples_git.bb19
1 files changed, 12 insertions, 7 deletions
diff --git a/meta/recipes-graphics/vulkan/vulkan-samples_git.bb b/meta/recipes-graphics/vulkan/vulkan-samples_git.bb
index b7c38f6543..d60c0f3190 100644
--- a/meta/recipes-graphics/vulkan/vulkan-samples_git.bb
+++ b/meta/recipes-graphics/vulkan/vulkan-samples_git.bb
@@ -1,17 +1,19 @@
1DESCRIPTION = "The Vulkan Samples is collection of resources to help develop optimized Vulkan applications." 1SUMMARY = "The Vulkan Samples is collection of resources to help develop optimized Vulkan applications."
2HOMEPAGE = "https://www.khronos.org/vulkan/" 2HOMEPAGE = "https://www.khronos.org/vulkan/"
3BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Samples/issues" 3BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Samples/issues"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5 5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=48aa35cefb768436223a6e7f18dc2a2a" 6LIC_FILES_CHKSUM = "file://LICENSE;md5=48aa35cefb768436223a6e7f18dc2a2a"
7 7
8SRC_URI = "gitsm://github.com/KhronosGroup/Vulkan-Samples.git \ 8SRC_URI = "gitsm://github.com/KhronosGroup/Vulkan-Samples.git;branch=main;protocol=https;lfs=0 \
9 file://0001-CMakeLists.txt-do-not-hardcode-lib-as-installation-t.patch \ 9 file://0001-vulkan-samples-Fix-reproducibility-issue.patch \
10 file://debugfix.patch \ 10 file://0001-Do-not-use-LFS64-functions-on-linux-musl.patch;patchdir=third_party/spdlog \
11 file://0001-Deprecate-u8string_view.patch;patchdir=third_party/spdlog \
12 file://32bit.patch \
11 " 13 "
12 14
13UPSTREAM_CHECK_COMMITS = "1" 15UPSTREAM_CHECK_COMMITS = "1"
14SRCREV = "55cebd9e7cc4153a3a7b3a45d42274c0e2a17815" 16SRCREV = "2307c3eb5608cb1205fa3514b3a31dbfb857d00c"
15 17
16UPSTREAM_CHECK_GITTAGREGEX = "These are not the releases you're looking for" 18UPSTREAM_CHECK_GITTAGREGEX = "These are not the releases you're looking for"
17S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
@@ -20,15 +22,18 @@ REQUIRED_DISTRO_FEATURES = 'vulkan'
20 22
21inherit cmake features_check 23inherit cmake features_check
22 24
23FILES_${PN} += "${datadir}" 25FILES:${PN} += "${datadir}"
24 26
25# 27#
26# There is code to remove the prefix CMAKE_SOURCE_DIR from __FILENAME__ paths 28# There is code to remove the prefix CMAKE_SOURCE_DIR from __FILENAME__ paths
27# used for logging with LOGE in the code. We need to make this match the value we use 29# used for logging with LOGE in the code. We need to make this match the value we use
28# in the debug source remapping from CFLAGS 30# in the debug source remapping from CFLAGS
29# 31#
30EXTRA_OECMAKE += "-DCMAKE_DEBUG_SRCDIR=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/" 32EXTRA_OECMAKE += "-DCMAKE_DEBUG_SRCDIR=${TARGET_DBGSRC_DIR}/"
31# Binaries built with PCH enabled don't appear reproducible, differing results were seen 33# Binaries built with PCH enabled don't appear reproducible, differing results were seen
32# from some builds depending on the point the PCH was compiled. Disable it to be 34# from some builds depending on the point the PCH was compiled. Disable it to be
33# deterministic 35# deterministic
34EXTRA_OECMAKE += "-DCMAKE_DISABLE_PRECOMPILE_HEADERS=ON" 36EXTRA_OECMAKE += "-DCMAKE_DISABLE_PRECOMPILE_HEADERS=ON"
37
38# This needs to be specified explicitly to avoid xcb/xlib dependencies
39EXTRA_OECMAKE += "-DVKB_WSI_SELECTION=D2D"