summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/ttf-fonts/liberation-fonts_2.00.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/ttf-fonts/liberation-fonts_2.00.1.bb')
-rw-r--r--meta/recipes-graphics/ttf-fonts/liberation-fonts_2.00.1.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-graphics/ttf-fonts/liberation-fonts_2.00.1.bb b/meta/recipes-graphics/ttf-fonts/liberation-fonts_2.00.1.bb
new file mode 100644
index 0000000000..412da48725
--- /dev/null
+++ b/meta/recipes-graphics/ttf-fonts/liberation-fonts_2.00.1.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Liberation(tm) Fonts"
2DESCRIPTION = "The Liberation(tm) Fonts is a font family originally \
3created by Ascender(c) which aims at metric compatibility with \
4Arial, Times New Roman, Courier New."
5HOMEPAGE = "https://releases.pagure.org/liberation-fonts/"
6BUGTRACKER = "https://bugzilla.redhat.com/"
7
8SECTION = "x11/fonts"
9LICENSE = "OFL-1.1"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=f96db970a9a46c5369142b99f530366b"
11PE = "1"
12
13inherit allarch fontcache
14
15FONT_PACKAGES = "${PN}"
16
17SRC_URI = "https://releases.pagure.org/liberation-fonts/liberation-fonts-ttf-${PV}.tar.gz \
18 file://30-liberation-aliases.conf"
19
20S = "${WORKDIR}/liberation-fonts-ttf-${PV}"
21
22SRC_URI[md5sum] = "5c781723a0d9ed6188960defba8e91cf"
23SRC_URI[sha256sum] = "7890278a6cd17873c57d9cd785c2d230d9abdea837e96516019c5885dd271504"
24
25do_install () {
26 install -d ${D}${datadir}/fonts/ttf/
27 for i in *.ttf; do
28 install -m 0644 $i ${D}${prefix}/share/fonts/ttf/${i}
29 done
30
31 install -d ${D}${sysconfdir}/fonts/conf.d/
32 install -m 0644 ${WORKDIR}/30-liberation-aliases.conf ${D}${sysconfdir}/fonts/conf.d/
33
34 install -d ${D}${prefix}/share/doc/${BPN}/
35 install -m 0644 LICENSE ${D}${datadir}/doc/${BPN}/
36}
37
38PACKAGES = "${PN}"
39FILES_${PN} += "${sysconfdir} ${datadir}"