summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/spir/spirv-tools_1.3.280.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/spir/spirv-tools_1.3.280.0.bb')
-rw-r--r--meta/recipes-graphics/spir/spirv-tools_1.3.280.0.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-graphics/spir/spirv-tools_1.3.280.0.bb b/meta/recipes-graphics/spir/spirv-tools_1.3.280.0.bb
new file mode 100644
index 0000000000..d2b6acf946
--- /dev/null
+++ b/meta/recipes-graphics/spir/spirv-tools_1.3.280.0.bb
@@ -0,0 +1,47 @@
1SUMMARY = "The SPIR-V Tools project provides an API and commands for \
2processing SPIR-V modules"
3DESCRIPTION = "The project includes an assembler, binary module parser, \
4disassembler, validator, and optimizer for SPIR-V."
5HOMEPAGE = "https://github.com/KhronosGroup/SPIRV-Tools"
6SECTION = "graphics"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
9
10SRCREV = "04896c462d9f3f504c99a4698605b6524af813c1"
11SRC_URI = "git://github.com/KhronosGroup/SPIRV-Tools.git;branch=main;protocol=https"
12PE = "1"
13# These recipes need to be updated in lockstep with each other:
14# glslang, vulkan-headers, vulkan-loader, vulkan-tools, spirv-headers, spirv-tools
15# vulkan-validation-layers, vulkan-utility-libraries.
16# The tags versions should always be sdk-x.y.z, as this is what
17# upstream considers a release.
18UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"
19S = "${WORKDIR}/git"
20
21inherit cmake
22
23DEPENDS = "spirv-headers"
24
25EXTRA_OECMAKE += "\
26 -DSPIRV-Headers_SOURCE_DIR=${STAGING_EXECPREFIXDIR} \
27 -DSPIRV_TOOLS_BUILD_STATIC=OFF \
28 -DBUILD_SHARED_LIBS=ON \
29 -DSPIRV_SKIP_TESTS=ON \
30"
31
32do_install:append:class-target() {
33 # Properly set _IMPORT_PREFIX in INTERFACE_LINK_LIBRARIES so that dependent
34 # tools can find the right library
35 sed -i ${D}${libdir}/cmake/SPIRV-Tools/SPIRV-ToolsTarget.cmake \
36 -e 's:INTERFACE_LINK_LIBRARIES.*$:INTERFACE_LINK_LIBRARIES "\$\{_IMPORT_PREFIX\}/${baselib}":'
37}
38
39# all the libraries are unversioned, so don't pack it on PN-dev
40SOLIBS = ".so"
41FILES_SOLIBSDEV = ""
42
43PACKAGES =+ "${PN}-lesspipe"
44FILES:${PN}-lesspipe = "${base_bindir}/spirv-lesspipe.sh"
45RDEPENDS:${PN}-lesspipe += "${PN} bash"
46
47BBCLASSEXTEND = "native nativesdk"