summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/shaderc/shaderc_2019.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/shaderc/shaderc_2019.0.bb')
-rw-r--r--meta/recipes-graphics/shaderc/shaderc_2019.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-graphics/shaderc/shaderc_2019.0.bb b/meta/recipes-graphics/shaderc/shaderc_2019.0.bb
new file mode 100644
index 0000000000..3bd9c61a55
--- /dev/null
+++ b/meta/recipes-graphics/shaderc/shaderc_2019.0.bb
@@ -0,0 +1,34 @@
1SUMMARY = "A collection of tools, libraries and tests for shader compilation"
2DESCRIPTION = "The Shaderc library provides an API for compiling GLSL/HLSL \
3source code to SPIRV modules. It has been shipping in the Android NDK since version r12b."
4SECTION = "graphics"
5HOMEPAGE = "https://github.com/google/shaderc"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9SRCREV = "34c412f21f945f4ef6ed4453f8b5dc4bb9d739e4"
10SRC_URI = "git://github.com/google/shaderc.git;protocol=https;branch=main \
11 file://0001-Fix-the-link-order-of-libglslang-and-libHLSL.patch \
12 file://0002-shaderc-2019.0-fix-build-against-new-glslang.patch \
13 file://0003-cmake-de-vendor-libs-and-disable-git-versioning.patch \
14 "
15S = "${WORKDIR}/git"
16
17inherit cmake python3native
18
19DEPENDS = "spirv-tools glslang"
20
21EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release -DSHADERC_SKIP_TESTS=ON"
22
23do_configure_prepend() {
24 # TODO: probably there is better solution for this.
25 # I dont know any method for get the version of a receipe in DEPENDS
26 # so do this ugly hack
27 cat <<- EOF > ${S}/glslc/src/build-version.inc
28"${PV}\\n"
29"$(pkg-config --modversion SPIRV-Tools)\\n"
30"$(glslangValidator --version | head -1 | cut -d' ' -f3)\\n"
31EOF
32}
33
34BBCLASSEXTEND = "native nativesdk"