summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/piglit/piglit_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/piglit/piglit_git.bb')
-rw-r--r--meta/recipes-graphics/piglit/piglit_git.bb39
1 files changed, 20 insertions, 19 deletions
diff --git a/meta/recipes-graphics/piglit/piglit_git.bb b/meta/recipes-graphics/piglit/piglit_git.bb
index 14f4c75a2c..99d75e64f8 100644
--- a/meta/recipes-graphics/piglit/piglit_git.bb
+++ b/meta/recipes-graphics/piglit/piglit_git.bb
@@ -3,31 +3,27 @@ DESCRIPTION = "Piglit is an open-source test suite for OpenGL and OpenCL \
3implementations." 3implementations."
4HOMEPAGE = "https://gitlab.freedesktop.org/mesa/piglit" 4HOMEPAGE = "https://gitlab.freedesktop.org/mesa/piglit"
5BUGTRACKER = "https://gitlab.freedesktop.org/mesa/piglit/-/issues" 5BUGTRACKER = "https://gitlab.freedesktop.org/mesa/piglit/-/issues"
6LICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause" 6LICENSE = "MIT & LGPL-2.0-or-later & GPL-3.0-only & GPL-2.0-or-later & BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0" 7LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
8 8
9SRC_URI = "git://gitlab.freedesktop.org/mesa/piglit.git;protocol=https \ 9SRC_URI = "git://gitlab.freedesktop.org/mesa/piglit.git;protocol=https;branch=main \
10 file://0001-cmake-install-bash-completions-in-the-right-place.patch \ 10 file://0002-cmake-use-proper-WAYLAND_INCLUDE_DIRS-variable.patch \
11 file://0001-cmake-use-proper-WAYLAND_INCLUDE_DIRS-variable.patch \ 11 file://0003-tests-util-piglit-shader.c-do-not-hardcode-build-pat.patch \
12 file://0001-Add-a-missing-include-for-htobe32-definition.patch \ 12 file://0001-tests-Fix-narrowing-errors-seen-with-clang.patch \
13 file://0001-generated_tests-gen_tcs-tes_input_tests.py-do-not-ha.patch \ 13 file://0001-utils-Include-libgen.h-on-musl-linux-systems.patch \
14 file://0002-tests-util-piglit-shader.c-do-not-hardcode-build-pat.patch \
15 file://0001-serializer.py-make-.gz-files-reproducible.patch \
16 file://0001-framework-profile.py-make-test-lists-reproducible.patch \
17 file://0001-tests-shader.py-sort-the-file-list-before-working-on.patch \
18 " 14 "
19UPSTREAM_CHECK_COMMITS = "1" 15UPSTREAM_CHECK_COMMITS = "1"
20 16
21SRCREV = "d4d9353b7290ed22cb7349226a8e4017402d3f02" 17SRCREV = "22eaf6a91cfd57f7bb3df4e5068c2ac1472d4ec1"
22# (when PV goes above 1.0 remove the trailing r) 18# (when PV goes above 1.0 remove the trailing r)
23PV = "1.0+gitr${SRCPV}" 19PV = "1.0+gitr"
24 20
25S = "${WORKDIR}/git" 21S = "${WORKDIR}/git"
26 22
27X11_DEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxrender libglu', '', d)}" 23X11_DEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxrender libglu', '', d)}"
28X11_RDEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'mesa-demos', '', d)}" 24X11_RDEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'mesa-demos', '', d)}"
29 25
30DEPENDS = "libpng waffle libxkbcommon virtual/libgl python3-mako-native python3-numpy-native python3-six-native virtual/egl" 26DEPENDS = "libpng waffle libxkbcommon python3-mako-native python3-numpy-native python3-six-native virtual/egl"
31 27
32inherit cmake pkgconfig python3native features_check bash-completion 28inherit cmake pkgconfig python3native features_check bash-completion
33 29
@@ -40,34 +36,39 @@ REQUIRED_DISTRO_FEATURES += "opengl"
40export TEMP = "${B}/temp/" 36export TEMP = "${B}/temp/"
41do_compile[dirs] =+ "${B}/temp/" 37do_compile[dirs] =+ "${B}/temp/"
42 38
43PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" 39PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 glx', '', d)}"
44PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut," 40PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
41PACKAGECONFIG[glx] = "-DPIGLIT_BUILD_GLX_TESTS=ON,-DPIGLIT_BUILD_GLX_TESTS=OFF"
42PACKAGECONFIG[opencl] = "-DPIGLIT_BUILD_CL_TESTS=ON,-DPIGLIT_BUILD_CL_TESTS=OFF,virtual/opencl-icd"
45PACKAGECONFIG[x11] = "-DPIGLIT_BUILD_GL_TESTS=ON,-DPIGLIT_BUILD_GL_TESTS=OFF,${X11_DEPS}, ${X11_RDEPS}" 43PACKAGECONFIG[x11] = "-DPIGLIT_BUILD_GL_TESTS=ON,-DPIGLIT_BUILD_GL_TESTS=OFF,${X11_DEPS}, ${X11_RDEPS}"
44PACKAGECONFIG[vulkan] = "-DPIGLIT_BUILD_VK_TESTS=ON,-DPIGLIT_BUILD_VK_TESTS=OFF,glslang-native vulkan-loader,glslang"
46 45
47export PIGLIT_BUILD_DIR = "../../../../git" 46export PIGLIT_BUILD_DIR = "../../../../git"
48 47
49do_configure_prepend() { 48do_configure:prepend() {
50 if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then 49 if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
51 sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h 50 sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
52 sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h 51 sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
53 fi 52 fi
54} 53}
55 54
56# Forcibly strip because Piglit is *huge* 55# Forcibly strip because Piglit is *huge*, and don't bother trying to split/strip the result.
57OECMAKE_TARGET_INSTALL = "install/strip" 56OECMAKE_TARGET_INSTALL = "install/strip"
57INHIBIT_PACKAGE_STRIP = "1"
58INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
58 59
59RDEPENDS_${PN} = "waffle waffle-bin python3 python3-mako python3-json \ 60RDEPENDS:${PN} = "waffle waffle-bin python3 python3-mako python3-json \
60 python3-misc \ 61 python3-misc \
61 python3-unixadmin python3-xml python3-multiprocessing \ 62 python3-unixadmin python3-xml python3-multiprocessing \
62 python3-six python3-shell python3-io \ 63 python3-six python3-shell python3-io \
63 python3-netserver bash \ 64 python3-netserver bash \
64 " 65 "
65 66
66INSANE_SKIP_${PN} += "dev-so already-stripped" 67INSANE_SKIP:${PN} += "dev-so already-stripped"
67 68
68# As nothing builds against Piglit we don't need to have anything in the 69# As nothing builds against Piglit we don't need to have anything in the
69# sysroot, especially when this is ~2GB of test suite 70# sysroot, especially when this is ~2GB of test suite
70SYSROOT_DIRS_remove = "${libdir}" 71SYSROOT_DIRS:remove = "${libdir}"
71 72
72# Can't be built with ccache 73# Can't be built with ccache
73CCACHE_DISABLE = "1" 74CCACHE_DISABLE = "1"