summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/pango/pango_1.52.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/pango/pango_1.52.2.bb')
-rw-r--r--meta/recipes-graphics/pango/pango_1.52.2.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-graphics/pango/pango_1.52.2.bb b/meta/recipes-graphics/pango/pango_1.52.2.bb
new file mode 100644
index 0000000000..4f748e6554
--- /dev/null
+++ b/meta/recipes-graphics/pango/pango_1.52.2.bb
@@ -0,0 +1,53 @@
1SUMMARY = "Framework for layout and rendering of internationalized text"
2DESCRIPTION = "Pango is a library for laying out and rendering of text, \
3with an emphasis on internationalization. Pango can be used anywhere \
4that text layout is needed, though most of the work on Pango so far has \
5been done in the context of the GTK+ widget toolkit. Pango forms the \
6core of text and font handling for GTK+-2.x."
7HOMEPAGE = "http://www.pango.org/"
8BUGTRACKER = "http://bugzilla.gnome.org"
9SECTION = "libs"
10LICENSE = "LGPL-2.0-or-later"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
13
14
15inherit gnomebase gi-docgen ptest-gnome upstream-version-is-even gobject-introspection
16
17UPSTREAM_CHECK_REGEX = "pango-(?P<pver>\d+\.(?!9\d+)\d+\.\d+)"
18
19GIR_MESON_ENABLE_FLAG = "enabled"
20GIR_MESON_DISABLE_FLAG = "disabled"
21
22SRC_URI += "file://run-ptest \
23 file://0001-Skip-running-test-layout-test.patch \
24 "
25
26SRC_URI[archive.sha256sum] = "d0076afe01082814b853deec99f9349ece5f2ce83908b8e58ff736b41f78a96b"
27
28DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi"
29
30PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \
31 ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
32
33PACKAGECONFIG[x11] = ",,virtual/libx11 libxft"
34PACKAGECONFIG[tests] = "-Dinstall-tests=true, -Dinstall-tests=false"
35PACKAGECONFIG[thai] = "-Dlibthai=enabled,-Dlibthai=disabled,libthai"
36
37GIR_MESON_OPTION = 'introspection'
38
39do_configure:prepend() {
40 chmod +x ${S}/tests/*.py
41}
42
43LEAD_SONAME = "libpango-1.0*"
44
45FILES:${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}"
46
47RDEPENDS:${PN}-ptest += "cantarell-fonts"
48RDEPENDS:${PN}-ptest:append:libc-glibc = " locale-base-en-us"
49
50RPROVIDES:${PN} += "pango-modules pango-module-indic-lang \
51 pango-module-basic-fc pango-module-arabic-lang"
52
53BBCLASSEXTEND = "native nativesdk"