summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/pango/pango_1.46.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/pango/pango_1.46.0.bb')
-rw-r--r--meta/recipes-graphics/pango/pango_1.46.0.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-graphics/pango/pango_1.46.0.bb b/meta/recipes-graphics/pango/pango_1.46.0.bb
new file mode 100644
index 0000000000..54440ea786
--- /dev/null
+++ b/meta/recipes-graphics/pango/pango_1.46.0.bb
@@ -0,0 +1,47 @@
1SUMMARY = "Framework for layout and rendering of internationalized text"
2DESCRIPTION = "Pango is a library for laying out and rendering of text, \
3with an emphasis on internationalization. Pango can be used anywhere \
4that text layout is needed, though most of the work on Pango so far has \
5been done in the context of the GTK+ widget toolkit. Pango forms the \
6core of text and font handling for GTK+-2.x."
7HOMEPAGE = "http://www.pango.org/"
8BUGTRACKER = "http://bugzilla.gnome.org"
9SECTION = "libs"
10LICENSE = "LGPLv2.0+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
13
14GNOMEBASEBUILDCLASS = "meson"
15
16inherit gnomebase gtk-doc ptest-gnome upstream-version-is-even gobject-introspection
17
18SRC_URI += " file://run-ptest"
19SRC_URI[archive.sha256sum] = "9a81572ebb946187fbdd69d5ffc57e2f7a1f768cd8d2fd89dbb03fb9002a99b5"
20
21DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi"
22
23PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \
24 ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
25
26PACKAGECONFIG[x11] = ",,virtual/libx11 libxft"
27PACKAGECONFIG[tests] = "-Dinstall-tests=true, -Dinstall-tests=false"
28PACKAGECONFIG[thai] = ",,libthai"
29
30GTKDOC_MESON_OPTION = "gtk_doc"
31GIR_MESON_OPTION = 'introspection'
32
33do_configure_prepend_toolchain-clang() {
34 sed -i -e "/Werror=implicit-fallthrough/d" ${S}/meson.build
35}
36
37LEAD_SONAME = "libpango-1.0*"
38
39FILES_${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}"
40
41RDEPENDS_${PN}-ptest += "cantarell-fonts"
42RDEPENDS_${PN}-ptest_append_libc-glibc = " locale-base-en-us"
43
44RPROVIDES_${PN} += "pango-modules pango-module-indic-lang \
45 pango-module-basic-fc pango-module-arabic-lang"
46
47BBCLASSEXTEND = "native nativesdk"