summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/pango/pango_1.44.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/pango/pango_1.44.5.bb')
-rw-r--r--meta/recipes-graphics/pango/pango_1.44.5.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-graphics/pango/pango_1.44.5.bb b/meta/recipes-graphics/pango/pango_1.44.5.bb
new file mode 100644
index 0000000000..a143723c7c
--- /dev/null
+++ b/meta/recipes-graphics/pango/pango_1.44.5.bb
@@ -0,0 +1,45 @@
1SUMMARY = "Framework for layout and rendering of internationalized text"
2DESCRIPTION = "Pango is a library for laying out and rendering of text, \
3with an emphasis on internationalization. Pango can be used anywhere \
4that text layout is needed, though most of the work on Pango so far has \
5been done in the context of the GTK+ widget toolkit. Pango forms the \
6core of text and font handling for GTK+-2.x."
7HOMEPAGE = "http://www.pango.org/"
8BUGTRACKER = "http://bugzilla.gnome.org"
9SECTION = "libs"
10LICENSE = "LGPLv2.0+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
13
14GNOMEBASEBUILDCLASS = "meson"
15
16inherit gnomebase gtk-doc ptest-gnome upstream-version-is-even gobject-introspection
17
18SRC_URI += "file://run-ptest"
19SRC_URI[archive.md5sum] = "b6bf689e3ce4f46b0fd887b64c850ea1"
20SRC_URI[archive.sha256sum] = "8527dfcbeedb4390149b6f94620c0fa64e26046ab85042c2a7556438847d7fc1"
21
22DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi"
23
24PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \
25 ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
26
27PACKAGECONFIG[x11] = ",,virtual/libx11 libxft"
28PACKAGECONFIG[tests] = "-Dinstall-tests=true, -Dinstall-tests=false"
29
30GTKDOC_MESON_OPTION = "gtk_doc"
31GIR_MESON_OPTION = 'introspection'
32
33LEAD_SONAME = "libpango-1.0*"
34LIBV = "1.8.0"
35
36FILES_${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}"
37FILES_${PN}-dev += "${libdir}/pango/${LIBV}/modules/*.la"
38
39RDEPENDS_${PN}-ptest += "cantarell-fonts"
40RDEPENDS_${PN}-ptest_append_libc-glibc = " locale-base-en-us"
41
42RPROVIDES_${PN} += "pango-modules pango-module-indic-lang \
43 pango-module-basic-fc pango-module-arabic-lang"
44
45BBCLASSEXTEND = "native nativesdk"