summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/pango/pango_1.42.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/pango/pango_1.42.4.bb')
-rw-r--r--meta/recipes-graphics/pango/pango_1.42.4.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-graphics/pango/pango_1.42.4.bb b/meta/recipes-graphics/pango/pango_1.42.4.bb
new file mode 100644
index 0000000000..e73fd28dfd
--- /dev/null
+++ b/meta/recipes-graphics/pango/pango_1.42.4.bb
@@ -0,0 +1,47 @@
1SUMMARY = "Framework for layout and rendering of internationalized text"
2DESCRIPTION = "Pango is a library for laying out and rendering of text, \
3with an emphasis on internationalization. Pango can be used anywhere \
4that text layout is needed, though most of the work on Pango so far has \
5been done in the context of the GTK+ widget toolkit. Pango forms the \
6core of text and font handling for GTK+-2.x."
7HOMEPAGE = "http://www.pango.org/"
8BUGTRACKER = "http://bugzilla.gnome.org"
9SECTION = "libs"
10LICENSE = "LGPLv2.0+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
13
14inherit gnomebase gtk-doc ptest-gnome upstream-version-is-even gobject-introspection
15
16SRC_URI += "file://run-ptest \
17 file://0001-Enforce-recreation-of-docs-pango.types-it-is-build-c.patch \
18"
19SRC_URI[archive.md5sum] = "deb171a31a3ad76342d5195a1b5bbc7c"
20SRC_URI[archive.sha256sum] = "1d2b74cd63e8bd41961f2f8d952355aa0f9be6002b52c8aa7699d9f5da597c9d"
21
22DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi"
23
24PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
25PACKAGECONFIG[x11] = "--with-xft,--without-xft,virtual/libx11 libxft"
26
27EXTRA_OECONF = "--disable-debug"
28
29LEAD_SONAME = "libpango-1.0*"
30LIBV = "1.8.0"
31
32# This binary needs to be compiled for the host architecture. This isn't pretty!
33do_compile_prepend_class-target () {
34 if ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'true', 'false', d)}; then
35 make CC="${BUILD_CC}" CFLAGS="" LDFLAGS="${BUILD_LDFLAGS}" AM_CPPFLAGS="$(pkg-config-native --cflags glib-2.0)" gen_all_unicode_LDADD="$(pkg-config-native --libs glib-2.0)" -C ${B}/tests gen-all-unicode
36 fi
37}
38
39FILES_${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}"
40FILES_${PN}-dev += "${libdir}/pango/${LIBV}/modules/*.la"
41
42RDEPENDS_${PN}-ptest += "liberation-fonts cantarell-fonts"
43
44RPROVIDES_${PN} += "pango-modules pango-module-indic-lang \
45 pango-module-basic-fc pango-module-arabic-lang"
46
47BBCLASSEXTEND = "native"