summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/pango/pango_1.40.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/pango/pango_1.40.1.bb')
-rw-r--r--meta/recipes-graphics/pango/pango_1.40.1.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-graphics/pango/pango_1.40.1.bb b/meta/recipes-graphics/pango/pango_1.40.1.bb
new file mode 100644
index 0000000000..6e1e6c9be6
--- /dev/null
+++ b/meta/recipes-graphics/pango/pango_1.40.1.bb
@@ -0,0 +1,51 @@
1SUMMARY = "Framework for layout and rendering of internationalized text"
2DESCRIPTION = "Pango is a library for laying out and rendering of text, \
3with an emphasis on internationalization. Pango can be used anywhere \
4that text layout is needed, though most of the work on Pango so far has \
5been done in the context of the GTK+ widget toolkit. Pango forms the \
6core of text and font handling for GTK+-2.x."
7HOMEPAGE = "http://www.pango.org/"
8BUGTRACKER = "http://bugzilla.gnome.org"
9SECTION = "libs"
10LICENSE = "LGPLv2.0+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
13
14inherit gnomebase gtk-doc ptest-gnome upstream-version-is-even gobject-introspection
15
16SRC_URI += "file://run-ptest \
17 file://0001-Drop-introspection-macros-from-acinclude.m4.patch \
18"
19SRC_URI[archive.md5sum] = "6fc88c6529890d6c8e03074d57a3eceb"
20SRC_URI[archive.sha256sum] = "e27af54172c72b3ac6be53c9a4c67053e16c905e02addcf3a603ceb2005c1a40"
21
22DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz"
23
24PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
25PACKAGECONFIG[x11] = "--with-xft,--without-xft,virtual/libx11 libxft"
26
27EXTRA_AUTORECONF = ""
28
29EXTRA_OECONF = " \
30 --disable-debug \
31 "
32
33LEAD_SONAME = "libpango-1.0*"
34LIBV = "1.8.0"
35
36# This binary needs to be compiled for the host architecture. This isn't pretty!
37do_compile_prepend_class-target () {
38 if ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'true', 'false', d)}; then
39 make CC="${BUILD_CC}" CFLAGS="" LDFLAGS="" AM_CPPFLAGS="$(pkg-config-native --cflags glib-2.0)" gen_all_unicode_LDADD="$(pkg-config-native --libs glib-2.0)" -C ${B}/tests gen-all-unicode
40 fi
41}
42
43FILES_${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}"
44FILES_${PN}-dev += "${libdir}/pango/${LIBV}/modules/*.la"
45
46RDEPENDS_${PN}-ptest += "liberation-fonts cantarell-fonts"
47
48RPROVIDES_${PN} += "pango-modules pango-module-indic-lang \
49 pango-module-basic-fc pango-module-arabic-lang"
50
51BBCLASSEXTEND = "native"