summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa_19.3.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa_19.3.3.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa_19.3.3.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa_19.3.3.bb b/meta/recipes-graphics/mesa/mesa_19.3.3.bb
new file mode 100644
index 0000000000..7e0c5d6500
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa_19.3.3.bb
@@ -0,0 +1,25 @@
1require ${BPN}.inc
2
3SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
4 file://0001-meson.build-check-for-all-linux-host_os-combinations.patch \
5 file://0002-meson.build-make-TLS-ELF-optional.patch \
6 file://0003-Allow-enable-DRI-without-DRI-drivers.patch \
7 file://0004-Revert-mesa-Enable-asm-unconditionally-now-that-gen_.patch \
8 file://0005-vc4-use-intmax_t-for-formatted-output-of-timespec-me.patch \
9 file://0001-meson-misdetects-64bit-atomics-on-mips-clang.patch \
10 "
11
12SRC_URI[md5sum] = "00010e0bb8f6641276ff6cb3e9386114"
13SRC_URI[sha256sum] = "81ce4810bb25d61300f8104856461f4d49cf7cb794aa70cb572312e370c39f09"
14
15UPSTREAM_CHECK_GITTAGREGEX = "mesa-(?P<pver>\d+(\.\d+)+)"
16
17CFLAGS += "-fcommon"
18
19#because we cannot rely on the fact that all apps will use pkgconfig,
20#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
21do_install_append() {
22 if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
23 sed -i -e 's/^#elif defined(__unix__) && defined(EGL_NO_X11)$/#elif defined(__unix__) \&\& defined(EGL_NO_X11) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
24 fi
25}