summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa_18.0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa_18.0.2.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa_18.0.2.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa_18.0.2.bb b/meta/recipes-graphics/mesa/mesa_18.0.2.bb
new file mode 100644
index 0000000000..aaac1e58e1
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa_18.0.2.bb
@@ -0,0 +1,22 @@
1require ${BPN}.inc
2
3SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
4 file://disable-asm-on-non-gcc.patch \
5 file://Use-Python-3-to-execute-the-scripts.patch \
6 file://0001-Use-wayland-scanner-in-the-path.patch \
7 file://0002-hardware-gloat.patch \
8 file://llvm-config-version.patch \
9 file://0001-winsys-svga-drm-Include-sys-types.h.patch \
10 file://0001-Makefile.vulkan.am-explictly-add-lib-expat-to-intel-.patch \
11 "
12
13SRC_URI[md5sum] = "3c303da98ec2ce37c795baeba5aee31e"
14SRC_URI[sha256sum] = "98fa159768482dc568b9f8bf0f36c7acb823fa47428ffd650b40784f16b9e7b3"
15
16#because we cannot rely on the fact that all apps will use pkgconfig,
17#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
18do_install_append() {
19 if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
20 sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
21 fi
22}