summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa_17.3.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa_17.3.8.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa_17.3.8.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa_17.3.8.bb b/meta/recipes-graphics/mesa/mesa_17.3.8.bb
new file mode 100644
index 0000000000..2d3fd3ca38
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa_17.3.8.bb
@@ -0,0 +1,23 @@
1require ${BPN}.inc
2
3SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
4 file://disable-asm-on-non-gcc.patch \
5 file://Use-Python-3-to-execute-the-scripts.patch \
6 file://0001-Use-wayland-scanner-in-the-path.patch \
7 file://0002-hardware-gloat.patch \
8 file://llvm-config-version.patch \
9 file://0001-winsys-svga-drm-Include-sys-types.h.patch \
10 file://0001-Makefile.vulkan.am-explictly-add-lib-expat-to-intel-.patch \
11 file://0001-st-dri-Initialise-modifier-to-INVALID-for-DRI2.patch \
12 "
13
14SRC_URI[md5sum] = "203d1a79156ab6926f2d253b377e9d9d"
15SRC_URI[sha256sum] = "8f9d9bf281c48e4a8f5228816577263b4c655248dc7666e75034ab422951a6b1"
16
17#because we cannot rely on the fact that all apps will use pkgconfig,
18#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
19do_install_append() {
20 if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
21 sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
22 fi
23}