summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa_17.2.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa_17.2.4.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa_17.2.4.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa_17.2.4.bb b/meta/recipes-graphics/mesa/mesa_17.2.4.bb
new file mode 100644
index 0000000000..928cb920af
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa_17.2.4.bb
@@ -0,0 +1,24 @@
1require ${BPN}.inc
2
3SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
4 file://replace_glibc_check_with_linux.patch \
5 file://disable-asm-on-non-gcc.patch \
6 file://0001-Use-wayland-scanner-in-the-path.patch \
7 file://0002-hardware-gloat.patch \
8 file://vulkan-mkdir.patch \
9 file://llvm-config-version.patch \
10 file://0001-winsys-svga-drm-Include-sys-types.h.patch \
11 file://0001-configure.ac-Always-check-for-expat.patch \
12 file://0001-Makefile.vulkan.am-explictly-add-lib-expat-to-intel-.patch \
13 "
14
15SRC_URI[md5sum] = "cf0b7a297eedd0549cda5ba071d7561f"
16SRC_URI[sha256sum] = "5ba408fecd6e1132e5490eec1a2f04466214e4c65c8b89b331be844768c2e550"
17
18#because we cannot rely on the fact that all apps will use pkgconfig,
19#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
20do_install_append() {
21 if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
22 sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
23 fi
24}