summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa_17.1.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa_17.1.4.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa_17.1.4.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa_17.1.4.bb b/meta/recipes-graphics/mesa/mesa_17.1.4.bb
new file mode 100644
index 0000000000..2a1ecd3124
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa_17.1.4.bb
@@ -0,0 +1,19 @@
1require ${BPN}.inc
2
3SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
4 file://replace_glibc_check_with_linux.patch \
5 file://disable-asm-on-non-gcc.patch \
6 file://0001-Use-wayland-scanner-in-the-path.patch \
7 file://0002-hardware-gloat.patch \
8"
9
10SRC_URI[md5sum] = "be2ef7c9edec23b07f74f6512a6a6fa5"
11SRC_URI[sha256sum] = "06f3b0e6a28f0d20b7f3391cf67fe89ae98ecd0a686cd545da76557b6cec9cad"
12
13#because we cannot rely on the fact that all apps will use pkgconfig,
14#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
15do_install_append() {
16 if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
17 sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
18 fi
19}