summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa-dri_7.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa-dri_7.9.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa-dri_7.9.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-dri_7.9.bb b/meta/recipes-graphics/mesa/mesa-dri_7.9.bb
new file mode 100644
index 0000000000..6f0f984022
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa-dri_7.9.bb
@@ -0,0 +1,38 @@
1include mesa-common.inc
2
3LIC_FILES_CHKSUM = "file://docs/license.html;md5=7a3373c039b6b925c427755a4f779c1d"
4
5PROTO_DEPS = "xf86driproto glproto dri2proto"
6LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes expat \
7 libxml2-native talloc"
8
9DEPENDS = "${PROTO_DEPS} ${LIB_DEPS} mesa-dri-glsl-native"
10
11PR = "r0"
12
13SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2 \
14 file://crossfix.patch"
15
16# most of our targets do not have DRI so will use mesa-xlib
17DEFAULT_PREFERENCE = "-1"
18
19# Atom PCs have DRI support so use mesa-dri by default
20DEFAULT_PREFERENCE_atom-pc = "1"
21
22LEAD_SONAME = "libGL.so.1"
23
24EXTRA_OECONF += "--with-driver=dri --disable-egl --disable-gallium"
25
26python populate_packages_prepend() {
27 import os.path
28
29 dri_drivers_root = os.path.join(bb.data.getVar('libdir', d, 1), "dri")
30
31 do_split_packages(d, dri_drivers_root, '^(.*)_dri\.so$', 'mesa-dri-driver-%s', 'Mesa %s DRI driver', extra_depends='')
32}
33
34COMPATIBLE_HOST = '(i.86.*-linux|x86_64.*-linux)'
35
36PACKAGES_DYNAMIC = "mesa-dri-driver-*"
37
38FILES_${PN}-dbg += "${libdir}/dri/.debug/*"