summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa-demos_8.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa-demos_8.4.0.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa-demos_8.4.0.bb59
1 files changed, 0 insertions, 59 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-demos_8.4.0.bb b/meta/recipes-graphics/mesa/mesa-demos_8.4.0.bb
deleted file mode 100644
index 38bdbded29..0000000000
--- a/meta/recipes-graphics/mesa/mesa-demos_8.4.0.bb
+++ /dev/null
@@ -1,59 +0,0 @@
1SUMMARY = "Mesa demo applications"
2DESCRIPTION = "This package includes the demonstration application, such as glxgears. \
3These applications can be used for Mesa validation and benchmarking."
4HOMEPAGE = "http://mesa3d.org"
5BUGTRACKER = "https://bugs.freedesktop.org"
6SECTION = "x11"
7
8LICENSE = "MIT & PD"
9LIC_FILES_CHKSUM = "file://src/xdemos/glxgears.c;beginline=1;endline=20;md5=914225785450eff644a86c871d3ae00e \
10 file://src/xdemos/glxdemo.c;beginline=1;endline=8;md5=b01d5ab1aee94d35b7efaa2ef48e1a06"
11
12SRC_URI = "https://mesa.freedesktop.org/archive/demos/${BPN}-${PV}.tar.bz2 \
13 file://0001-mesa-demos-Add-missing-data-files.patch \
14 file://0003-configure-Allow-to-disable-demos-which-require-GLEW-.patch \
15 file://0004-Use-DEMOS_DATA_DIR-to-locate-data-files.patch \
16 file://0007-Install-few-more-test-programs.patch \
17 file://0008-glsl-perf-Add-few-missing-.glsl-.vert-.frag-files-to.patch \
18 file://0009-glsl-perf-Install-.glsl-.vert-.frag-files.patch \
19 file://0012-mesa-demos-OpenVG-demos-with-single-frame-need-eglSw.patch \
20 file://0013-only-build-GLX-demos-if-needed.patch \
21 "
22SRC_URI[md5sum] = "6b65a02622765522176d00f553086fa3"
23SRC_URI[sha256sum] = "01e99c94a0184e63e796728af89bfac559795fb2a0d6f506fa900455ca5fff7d"
24
25inherit autotools pkgconfig features_check
26# depends on virtual/egl, virtual/libgl ...
27REQUIRED_DISTRO_FEATURES = "opengl x11"
28
29PACKAGECONFIG ?= "drm osmesa freetype2 gbm egl gles1 gles2 \
30 x11 glew glu glx"
31
32# The Wayland code doesn't work with Wayland 1.0, so disable it for now
33#${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)}"
34
35EXTRA_OECONF = "--with-system-data-files"
36
37PACKAGECONFIG[drm] = "--enable-libdrm,--disable-libdrm,libdrm"
38PACKAGECONFIG[egl] = "--enable-egl,--disable-egl,virtual/egl"
39PACKAGECONFIG[freetype2] = "--enable-freetype2,--disable-freetype2,freetype"
40PACKAGECONFIG[gbm] = "--enable-gbm,--disable-gbm,virtual/libgl"
41PACKAGECONFIG[gles1] = "--enable-gles1,--disable-gles1,virtual/libgles1"
42PACKAGECONFIG[gles2] = "--enable-gles2,--disable-gles2,virtual/libgles2"
43PACKAGECONFIG[glut] = "--with-glut=${STAGING_EXECPREFIXDIR},--without-glut,freeglut"
44PACKAGECONFIG[osmesa] = "--enable-osmesa,--disable-osmesa,"
45PACKAGECONFIG[vg] = "--enable-vg,--disable-vg,virtual/libopenvg"
46PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,virtual/libgl wayland"
47PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11"
48PACKAGECONFIG[glew] = "--enable-glew,--disable-glew,glew"
49PACKAGECONFIG[glu] = "--enable-glu,--disable-glu,virtual/libgl"
50PACKAGECONFIG[glx] = "--enable-glx-demos,--disable-glx-demos"
51
52do_install_append() {
53 # it can be completely empty when all PACKAGECONFIG options are disabled
54 rmdir --ignore-fail-on-non-empty ${D}${bindir}
55
56 if [ -f ${D}${bindir}/clear ]; then
57 mv ${D}${bindir}/clear ${D}${bindir}/clear.mesa-demos
58 fi
59}