summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.3.bb')
-rw-r--r--meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.3.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.3.bb b/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.3.bb
new file mode 100644
index 0000000000..c8b6f07ed0
--- /dev/null
+++ b/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.3.bb
@@ -0,0 +1,38 @@
1SUMMARY = "Matchbox lightweight window manager"
2HOMEPAGE = "http://matchbox-project.org"
3BUGTRACKER = "http://bugzilla.yoctoproject.org/"
4
5LICENSE = "GPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://src/wm.h;endline=21;md5=ce20617ac10f26045cc57b8d977ab552 \
7 file://src/main.c;endline=21;md5=508f280276140250ce483e0a44f7a9ec \
8 file://src/wm.c;endline=21;md5=f54584fb0d48cfc2e6876e0f0e272e6c"
9
10SECTION = "x11/wm"
11DEPENDS = "libmatchbox virtual/libx11 libxext libxrender startup-notification expat gconf libxcursor libxfixes"
12
13SRCREV = "ce8c1053270d960a7235ab5c3435f707541810a4"
14SRC_URI = "git://git.yoctoproject.org/matchbox-window-manager;branch=master;protocol=https \
15 file://kbdconfig"
16
17S = "${WORKDIR}/git"
18
19inherit autotools pkgconfig features_check
20# depends on virtual/libx11
21REQUIRED_DISTRO_FEATURES = "x11"
22
23FILES:${PN} = "${bindir}/* \
24 ${datadir}/matchbox \
25 ${sysconfdir}/matchbox \
26 ${datadir}/themes/blondie/matchbox \
27 ${datadir}/themes/Default/matchbox \
28 ${datadir}/themes/MBOpus/matchbox"
29
30EXTRA_OECONF = " --enable-startup-notification \
31 --disable-xrm \
32 --enable-expat \
33 --with-expat-lib=${STAGING_LIBDIR} \
34 --with-expat-includes=${STAGING_INCDIR}"
35
36do_install:prepend() {
37 install ${UNPACKDIR}/kbdconfig ${S}/data/kbdconfig
38}