summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libsdl2/libsdl2_2.0.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/libsdl2/libsdl2_2.0.8.bb')
-rw-r--r--meta/recipes-graphics/libsdl2/libsdl2_2.0.8.bb65
1 files changed, 65 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libsdl2/libsdl2_2.0.8.bb b/meta/recipes-graphics/libsdl2/libsdl2_2.0.8.bb
new file mode 100644
index 0000000000..c0cf70d7fd
--- /dev/null
+++ b/meta/recipes-graphics/libsdl2/libsdl2_2.0.8.bb
@@ -0,0 +1,65 @@
1SUMMARY = "Simple DirectMedia Layer"
2DESCRIPTION = "Simple DirectMedia Layer is a cross-platform multimedia \
3library designed to provide low level access to audio, keyboard, mouse, \
4joystick, 3D hardware via OpenGL, and 2D video framebuffer."
5HOMEPAGE = "http://www.libsdl.org"
6BUGTRACKER = "http://bugzilla.libsdl.org/"
7
8SECTION = "libs"
9
10LICENSE = "Zlib"
11LIC_FILES_CHKSUM = "file://COPYING.txt;md5=02ee26814dd044bd7838ae24e05b880f"
12
13PROVIDES = "virtual/libsdl2"
14
15DEPENDS_class-nativesdk = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/nativesdk-libx11 nativesdk-libxrandr nativesdk-libxrender nativesdk-libxext', '', d)}"
16
17SRC_URI = " \
18 http://www.libsdl.org/release/SDL2-${PV}.tar.gz \
19"
20
21S = "${WORKDIR}/SDL2-${PV}"
22
23SRC_URI[md5sum] = "3800d705cef742c6a634f202c37f263f"
24SRC_URI[sha256sum] = "edc77c57308661d576e843344d8638e025a7818bff73f8fbfab09c3c5fd092ec"
25
26inherit autotools lib_package binconfig pkgconfig
27
28EXTRA_OECONF = "--disable-oss --disable-esd --disable-arts \
29 --disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \
30 --disable-video-dummy \
31 --enable-pthreads \
32 --enable-sdl-dlopen \
33 --disable-rpath \
34 "
35
36# opengl packageconfig factored out to make it easy for distros
37# and BSP layers to pick either (desktop) opengl, gles2, or no GL
38PACKAGECONFIG_GL ?= "${@bb.utils.filter('DISTRO_FEATURES', 'opengl', d)}"
39
40PACKAGECONFIG ??= " \
41 ${PACKAGECONFIG_GL} \
42 ${@bb.utils.filter('DISTRO_FEATURES', 'alsa directfb pulseaudio x11', d)} \
43 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland gles2', '', d)} \
44"
45PACKAGECONFIG[alsa] = "--enable-alsa --disable-alsatest,--disable-alsa,alsa-lib,"
46PACKAGECONFIG[directfb] = "--enable-video-directfb,--disable-video-directfb,directfb"
47PACKAGECONFIG[gles2] = "--enable-video-opengles,--disable-video-opengles,virtual/libgles2"
48PACKAGECONFIG[opengl] = "--enable-video-opengl,--disable-video-opengl,virtual/libgl"
49PACKAGECONFIG[pulseaudio] = "--enable-pulseaudio,--disable-pulseaudio,pulseaudio"
50PACKAGECONFIG[tslib] = "--enable-input-tslib,--disable-input-tslib,tslib"
51PACKAGECONFIG[wayland] = "--enable-video-wayland,--disable-video-wayland,wayland-native wayland wayland-protocols libxkbcommon"
52PACKAGECONFIG[x11] = "--enable-video-x11,--disable-video-x11,virtual/libx11 libxext libxrandr libxrender"
53
54EXTRA_AUTORECONF += "--include=acinclude --exclude=autoheader"
55
56do_configure_prepend() {
57 # Remove old libtool macros.
58 MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
59 for i in ${MACROS}; do
60 rm -f ${S}/acinclude/$i
61 done
62 export SYSROOT=$PKG_CONFIG_SYSROOT_DIR
63}
64
65FILES_${PN}-dev += "${libdir}/cmake"