summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libsdl2/libsdl2_2.0.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/libsdl2/libsdl2_2.0.5.bb')
-rw-r--r--meta/recipes-graphics/libsdl2/libsdl2_2.0.5.bb70
1 files changed, 70 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libsdl2/libsdl2_2.0.5.bb b/meta/recipes-graphics/libsdl2/libsdl2_2.0.5.bb
new file mode 100644
index 0000000000..ac7312b92d
--- /dev/null
+++ b/meta/recipes-graphics/libsdl2/libsdl2_2.0.5.bb
@@ -0,0 +1,70 @@
1SUMMARY = "Simple DirectMedia Layer"
2DESCRIPTION = "Simple DirectMedia Layer is a cross-platform multimedia \
3library designed to provide low level access to audio, keyboard, mouse, \
4joystick, 3D hardware via OpenGL, and 2D video framebuffer."
5HOMEPAGE = "http://www.libsdl.org"
6BUGTRACKER = "http://bugzilla.libsdl.org/"
7
8SECTION = "libs"
9
10LICENSE = "Zlib"
11LIC_FILES_CHKSUM = "file://COPYING.txt;md5=b2304ad7e91711027590d3f102a754b7"
12
13PROVIDES = "virtual/libsdl2"
14
15DEPENDS_class-nativesdk = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/nativesdk-libx11 nativesdk-libxrandr nativesdk-libxrender nativesdk-libxext', '', d)}"
16
17SRC_URI = " \
18 http://www.libsdl.org/release/SDL2-${PV}.tar.gz \
19 file://linkage.patch \
20 file://0001-prepend-our-sysroot-path-so-that-make-finds-our-wayl.patch \
21"
22
23S = "${WORKDIR}/SDL2-${PV}"
24
25SRC_URI[md5sum] = "d4055424d556b4a908aa76fad63abd3c"
26SRC_URI[sha256sum] = "442038cf55965969f2ff06d976031813de643af9c9edc9e331bd761c242e8785"
27
28inherit autotools lib_package binconfig pkgconfig
29
30EXTRA_OECONF = "--disable-oss --disable-esd --disable-arts \
31 --disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \
32 --disable-video-dummy \
33 --enable-pthreads \
34 --enable-sdl-dlopen \
35 --disable-rpath \
36 WAYLAND_PROTOCOLS_SYSROOT_DIR=${STAGING_DIR}/${MACHINE}"
37
38# opengl packageconfig factored out to make it easy for distros
39# and BSP layers to pick either (desktop) opengl, gles2, or no GL
40PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'opengl', '', d)}"
41
42PACKAGECONFIG ??= " \
43 ${PACKAGECONFIG_GL} \
44 ${@bb.utils.contains('DISTRO_FEATURES', 'alsa', 'alsa', '', d)} \
45 ${@bb.utils.contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)} \
46 ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '', d)} \
47 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland gles2', '', d)} \
48 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \
49"
50PACKAGECONFIG[alsa] = "--enable-alsa --disable-alsatest,--disable-alsa,alsa-lib,"
51PACKAGECONFIG[directfb] = "--enable-video-directfb,--disable-video-directfb,directfb"
52PACKAGECONFIG[gles2] = "--enable-video-opengles,--disable-video-opengles,virtual/libgles2"
53PACKAGECONFIG[opengl] = "--enable-video-opengl,--disable-video-opengl,virtual/libgl"
54PACKAGECONFIG[pulseaudio] = "--enable-pulseaudio,--disable-pulseaudio,pulseaudio"
55PACKAGECONFIG[tslib] = "--enable-input-tslib,--disable-input-tslib,tslib"
56PACKAGECONFIG[wayland] = "--enable-video-wayland,--disable-video-wayland,wayland libxkbcommon"
57PACKAGECONFIG[x11] = "--enable-video-x11,--disable-video-x11,virtual/libx11 libxext libxrandr libxrender"
58
59EXTRA_AUTORECONF += "--include=acinclude --exclude=autoheader"
60
61do_configure_prepend() {
62 # Remove old libtool macros.
63 MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
64 for i in ${MACROS}; do
65 rm -f ${S}/acinclude/$i
66 done
67 export SYSROOT=$PKG_CONFIG_SYSROOT_DIR
68}
69
70FILES_${PN}-dev += "${libdir}/cmake"